summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 880840d..435cb53 100644
--- a/setup.py
+++ b/setup.py
@@ -43,7 +43,7 @@ def is_macosx_sdk_path(path):
"""
Returns True if 'path' can be located in an OSX SDK
"""
- return path.startswith('/usr/') or path.startswith('/System/')
+ return (path.startswith('/usr/') and not path.startswith('/usr/local')) or path.startswith('/System/')
def find_file(filename, std_dirs, paths):
"""Searches for the directory where a given file is located,
@@ -868,6 +868,7 @@ class PyBuildExt(build_ext):
else:
if os.path.isdir(dn):
tmp.append(dn)
+ db_dirs_to_check = tmp
db_dirs_to_check = tmp