Commit message (Collapse) | Author | Age | Files | Lines | ||
---|---|---|---|---|---|---|
... | ||||||
* | Root variable is not changed. | Raymond Hettinger | 2012-03-17 | 1 | -1/+1 | |
| | ||||||
* | Fix whitespace | Raymond Hettinger | 2012-03-17 | 1 | -1/+1 | |
| | ||||||
* | Unique sentinel value for cache.get() | Raymond Hettinger | 2012-03-17 | 1 | -2/+2 | |
| | ||||||
* | Refactor calculation of the cache key. Minor code cleanups. | Raymond Hettinger | 2012-03-16 | 1 | -25/+21 | |
| | ||||||
* | merge heads | Benjamin Peterson | 2012-03-16 | 1 | -2/+1 | |
|\ | ||||||
| * | Minor code cleanup. | Raymond Hettinger | 2012-03-16 | 1 | -2/+1 | |
| | | ||||||
* | | clear the root with the cache | Benjamin Peterson | 2012-03-16 | 1 | -1/+3 | |
|/ | ||||||
* | Eliminate duplicate link lookup. Minor cleanup. | Raymond Hettinger | 2012-03-16 | 1 | -2/+2 | |
| | ||||||
* | Improve the memory utilization (and speed) of functools.lru_cache(). | Raymond Hettinger | 2012-03-16 | 1 | -21/+32 | |
| | ||||||
* | Issue #13544: Add __qualname__ to functools.WRAPPER_ASSIGNMENTS. | Meador Inge | 2011-12-12 | 1 | -1/+2 | |
| | | | | Patch by Filip Gruszczyński. | |||||
* | Issue 13227: Option to make the lru_cache() type specific (suggested by ↵ | Raymond Hettinger | 2011-10-20 | 1 | -4/+18 | |
| | | | | Andrew Koenig). | |||||
* | Merge | Raymond Hettinger | 2011-10-16 | 1 | -15/+19 | |
|\ | ||||||
| * | Issue 13177: Make tracebacks more readable by avoiding chained exceptions in ↵ | Raymond Hettinger | 2011-10-16 | 1 | -15/+19 | |
| | | | | | | | | the lru_cache. | |||||
| * | Sync-up minor code edits with the default branch. | Raymond Hettinger | 2011-05-05 | 1 | -4/+4 | |
| | | ||||||
* | | Fix __hash__ in functools.cmp_to_key() to work with collections.Hashable. | Raymond Hettinger | 2011-05-03 | 1 | -2/+1 | |
|\ \ | |/ | ||||||
| * | Fix __hash__ in functools.cmp_to_key() to work with collections.Hashable. | Raymond Hettinger | 2011-05-03 | 1 | -2/+1 | |
| | | ||||||
* | | Issue #11707: Fast C version of functools.cmp_to_key() | Raymond Hettinger | 2011-04-05 | 1 | -1/+6 | |
| | | ||||||
* | | Issue #11628: cmp_to_key should use __slots__. | Raymond Hettinger | 2011-03-22 | 1 | -0/+1 | |
|\ \ | |/ | ||||||
| * | Issue #11628: cmp_to_key should use __slots__. | Raymond Hettinger | 2011-03-22 | 1 | -0/+1 | |
| | | ||||||
* | | Minor optimization -- factor a constant expression out of the inner-loop. | Raymond Hettinger | 2011-03-18 | 1 | -3/+3 | |
|/ | ||||||
* | Add comment. | Raymond Hettinger | 2011-01-11 | 1 | -1/+1 | |
| | ||||||
* | Issue #10042: Fixed the total_ordering decorator to handle cross-type | Raymond Hettinger | 2011-01-08 | 1 | -8/+8 | |
| | | | | comparisons that could lead to infinite recursion. | |||||
* | Issue 10593: Adopt Nick's suggestion for an lru_cache with maxsize=None. | Raymond Hettinger | 2010-12-01 | 1 | -19/+41 | |
| | ||||||
* | Doc and docstring nits. | Raymond Hettinger | 2010-12-01 | 1 | -2/+2 | |
| | ||||||
* | Add example, tighten text, and minor clean-ups. | Raymond Hettinger | 2010-11-30 | 1 | -2/+2 | |
| | ||||||
* | Neaten-up a bit. | Raymond Hettinger | 2010-11-30 | 1 | -7/+6 | |
| | ||||||
* | Issue 10586: change the new functools.lru_cache implementation to expose the ↵ | Nick Coghlan | 2010-11-30 | 1 | -7/+18 | |
| | | | | maximum and current cache sizes through the public statistics API. This API is now a single function that returns a named tuple. | |||||
* | Clean-up docstring, comments, and whitespace. | Raymond Hettinger | 2010-11-25 | 1 | -5/+15 | |
| | ||||||
* | Improve comment | Raymond Hettinger | 2010-09-16 | 1 | -1/+1 | |
| | ||||||
* | Future proof total_ordering against changes in methods defined on object. | Raymond Hettinger | 2010-09-14 | 1 | -1/+1 | |
| | ||||||
* | Revert r84700 which had an unfortunate performance cost. | Raymond Hettinger | 2010-09-11 | 1 | -2/+2 | |
| | ||||||
* | Separate positional arguments from localized globals. | Raymond Hettinger | 2010-09-11 | 1 | -2/+2 | |
| | ||||||
* | add reduce and partial to __all__ | Benjamin Peterson | 2010-09-10 | 1 | -1/+1 | |
| | ||||||
* | Add method to OrderedDict for repositioning keys to the ends. | Raymond Hettinger | 2010-09-06 | 1 | -1/+1 | |
| | ||||||
* | Clean-up functools.total_ordering(). | Raymond Hettinger | 2010-09-05 | 1 | -4/+2 | |
| | ||||||
* | Adopt more descriptive attribute names as suggested on python-dev. | Raymond Hettinger | 2010-09-04 | 1 | -6/+6 | |
| | ||||||
* | Readability nit. | Raymond Hettinger | 2010-09-02 | 1 | -1/+2 | |
| | ||||||
* | Better method name. Tighten inner-loop with bound methods. | Raymond Hettinger | 2010-09-02 | 1 | -2/+3 | |
| | ||||||
* | Speed-up cache updates | Raymond Hettinger | 2010-09-02 | 1 | -2/+1 | |
| | ||||||
* | remove parens | Benjamin Peterson | 2010-08-24 | 1 | -1/+1 | |
| | ||||||
* | run total_ordering() tests, and fix the function (default comparisons ↵ | Benjamin Peterson | 2010-08-23 | 1 | -1/+4 | |
| | | | | shouldn't be considered) | |||||
* | Document and test the resolution of issue 3445 (tolerate missing attributes ↵ | Nick Coghlan | 2010-08-17 | 1 | -2/+7 | |
| | | | | in functools.update_wrapper, previously implemented as a side effect of the __annotations__ copying patch) and implement issue 9567 (add a __wrapped__ attribute when using update_wrapper) | |||||
* | Fix __all__. | Raymond Hettinger | 2010-08-15 | 1 | -1/+1 | |
| | ||||||
* | Remove unused imports | Raymond Hettinger | 2010-08-15 | 1 | -3/+1 | |
| | ||||||
* | Remove the lfu_cache. Add more tests. | Raymond Hettinger | 2010-08-15 | 1 | -52/+0 | |
| | ||||||
* | Support cache sizes. | Raymond Hettinger | 2010-08-14 | 1 | -1/+1 | |
| | ||||||
* | Localize one more builtin lookup. | Raymond Hettinger | 2010-08-14 | 1 | -2/+4 | |
| | ||||||
* | Add locks to make the caches well behaved in multi-threaded code. | Raymond Hettinger | 2010-08-14 | 1 | -24/+39 | |
| | | | | | Store builtins in cell variables to speed-up the common path, reducing the chance of a lock needing to block at all. | |||||
* | use same quoting as the rest of the file | Benjamin Peterson | 2010-08-08 | 1 | -6/+6 | |
| | ||||||
* | Issue #8814: function annotations (the `__annotations__` attribute) | Antoine Pitrou | 2010-08-04 | 1 | -2/+3 | |
| | | | | | are now included in the set of attributes copied by default by functools.wraps and functools.update_wrapper. Patch by Terrence Cole. |