summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAbseil Team <absl-team@google.com>2022-10-19 04:39:44 (GMT)
committerCopybara-Service <copybara-worker@google.com>2022-10-19 04:40:24 (GMT)
commit6bad847991e663f2e2cc0fac1e72765763ab616b (patch)
tree38b8b5df0d5ff5a0f8940c4a5981c4a8260e79ad /CMakeLists.txt
parentf372c760264ad5fe672a96994d4a44190201e5c1 (diff)
downloadgoogletest-6bad847991e663f2e2cc0fac1e72765763ab616b.zip
googletest-6bad847991e663f2e2cc0fac1e72765763ab616b.tar.gz
googletest-6bad847991e663f2e2cc0fac1e72765763ab616b.tar.bz2
CMake: Add GTEST_HAS_ABSL build option for using Absl
PiperOrigin-RevId: 482101793 Change-Id: I1bd140fd6a325f573c8a0c464e4dccd4acd0d0a3
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 725d670..4210622 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -30,6 +30,7 @@ include(GNUInstallDirs)
#Note that googlemock target already builds googletest
option(BUILD_GMOCK "Builds the googlemock subproject" ON)
option(INSTALL_GTEST "Enable installation of googletest. (Projects embedding googletest may want to turn this OFF.)" ON)
+option(GTEST_HAS_ABSL "Use Abseil and RE2. Requires Abseil and RE2 to be separately added to the build." OFF)
if(BUILD_GMOCK)
add_subdirectory( googlemock )