summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormisterg <misterg@google.com>2018-10-01 17:26:47 (GMT)
committerGennadiy Civil <misterg@google.com>2018-10-01 18:31:07 (GMT)
commita7b21c950d801f44103f7d5c236b820294a5c828 (patch)
tree62a89ed8ee677b1043ab7e8cd7ee780aecd34b24 /CMakeLists.txt
parentbe429c892406eab931210947ed07df7cc8c0dc53 (diff)
downloadgoogletest-a7b21c950d801f44103f7d5c236b820294a5c828.zip
googletest-a7b21c950d801f44103f7d5c236b820294a5c828.tar.gz
googletest-a7b21c950d801f44103f7d5c236b820294a5c828.tar.bz2
Googletest exportrefs/pull/1875/head
Internal Change PiperOrigin-RevId: 215236414
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..b6b938f
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,24 @@
+cmake_minimum_required(VERSION 2.8.8)
+
+if (POLICY CMP0048)
+ cmake_policy(SET CMP0048 NEW)
+endif (POLICY CMP0048)
+
+project(googletest-distribution)
+set(GOOGLETEST_VERSION 1.9.0)
+set(CMAKE_CXX_STANDARD 11 CACHE STRING "Set the C++ standard to be used for compiling")
+
+enable_testing()
+
+include(CMakeDependentOption)
+include(GNUInstallDirs)
+
+#Note that googlemock target already builds googletest
+option(BUILD_GMOCK "Builds the googlemock subproject" ON)
+option(INSTALL_GTEST "Enable installation of googletest. (Projects embedding googletest may want to turn this OFF.)" ON)
+
+if(BUILD_GMOCK)
+ add_subdirectory( googlemock )
+else()
+ add_subdirectory( googletest )
+endif()