summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorzhanyong.wan <zhanyong.wan@861a406c-534a-0410-8894-cb66d6ee9925>2009-03-11 22:18:52 (GMT)
committerzhanyong.wan <zhanyong.wan@861a406c-534a-0410-8894-cb66d6ee9925>2009-03-11 22:18:52 (GMT)
commit87d23e45f096c91c9e722b20bf15b733dbab0f80 (patch)
tree371303a68075a9188a758ad359689fc579ff8388 /Makefile.am
parent3d8064999c838978bd271fcf78185f4e6f042f12 (diff)
downloadgoogletest-87d23e45f096c91c9e722b20bf15b733dbab0f80.zip
googletest-87d23e45f096c91c9e722b20bf15b733dbab0f80.tar.gz
googletest-87d23e45f096c91c9e722b20bf15b733dbab0f80.tar.bz2
Implements the --help flag; fixes tests on Windows.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index fc182d9..3d72d26 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -319,6 +319,12 @@ test_gtest_filter_unittest__LDADD = lib/libgtest.la
check_SCRIPTS += test/gtest_filter_unittest.py
TESTS += test/gtest_filter_unittest.py
+check_PROGRAMS += test/gtest_help_test_
+test_gtest_help_test__SOURCES = test/gtest_help_test_.cc
+test_gtest_help_test__LDADD = lib/libgtest_main.la
+check_SCRIPTS += test/gtest_help_test.py
+TESTS += test/gtest_help_test.py
+
check_PROGRAMS += test/gtest_list_tests_unittest_
test_gtest_list_tests_unittest__SOURCES = test/gtest_list_tests_unittest_.cc
test_gtest_list_tests_unittest__LDADD = lib/libgtest.la