summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorzhanyong.wan <zhanyong.wan@861a406c-534a-0410-8894-cb66d6ee9925>2009-06-11 03:33:05 (GMT)
committerzhanyong.wan <zhanyong.wan@861a406c-534a-0410-8894-cb66d6ee9925>2009-06-11 03:33:05 (GMT)
commit683f431d830dea27069e7eef11d355bae2b82b72 (patch)
tree002f2a1b5dd8ca41ff71134b966ed80cbfec5eee /Makefile.am
parentb24b49d85a741f254cbe42da36e0cb93f0b0b57f (diff)
downloadgoogletest-683f431d830dea27069e7eef11d355bae2b82b72.zip
googletest-683f431d830dea27069e7eef11d355bae2b82b72.tar.gz
googletest-683f431d830dea27069e7eef11d355bae2b82b72.tar.bz2
Works around a gcc bug when compiling tr1/tuple with RTTI disabled.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b030cd8..148a076 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -292,6 +292,14 @@ check_PROGRAMS += test/gtest_unittest
test_gtest_unittest_SOURCES = test/gtest_unittest.cc
test_gtest_unittest_LDADD = lib/libgtest_main.la
+# Verifies that Google Test works when RTTI is disabled.
+TESTS += test/gtest_no_rtti_test
+check_PROGRAMS += test/gtest_no_rtti_test
+test_gtest_no_rtti_test_SOURCES = test/gtest_unittest.cc \
+ src/gtest-all.cc \
+ src/gtest_main.cc
+test_gtest_no_rtti_test_CXXFLAGS = $(AM_CXXFLAGS) -fno-rtti -DGTEST_HAS_RTTI=0
+
# The following tests depend on the presence of a Python installation and are
# keyed off of it. TODO(chandlerc@google.com): While we currently only attempt
# to build and execute these tests if Autoconf has found Python v2.4 on the