summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorvladlosev <vladlosev@861a406c-534a-0410-8894-cb66d6ee9925>2009-10-20 21:03:10 (GMT)
committervladlosev <vladlosev@861a406c-534a-0410-8894-cb66d6ee9925>2009-10-20 21:03:10 (GMT)
commitbad778caa39a88b7c11b159e20730aeec4fd711e (patch)
treeab4f68a695479be0a9eaadcadc364f6c4b06d0c0 /Makefile.am
parent060804deb8c05b5ea5735b875eaea2c7493e2262 (diff)
downloadgoogletest-bad778caa39a88b7c11b159e20730aeec4fd711e.zip
googletest-bad778caa39a88b7c11b159e20730aeec4fd711e.tar.gz
googletest-bad778caa39a88b7c11b159e20730aeec4fd711e.tar.bz2
Implements support for AssertionResult in Boolean assertions such as EXPECT_TRUE; Fixes Google Tests's tuple implementation to default-initialize its fields in the default constructor (by Zhanyong Wan); Populates gtest_stress_test.cc with actual tests.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3a9233d..ec3e5ee 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -276,7 +276,9 @@ test_gtest_sole_header_test_LDADD = lib/libgtest_main.la
TESTS += test/gtest_stress_test
check_PROGRAMS += test/gtest_stress_test
test_gtest_stress_test_SOURCES = test/gtest_stress_test.cc
-test_gtest_stress_test_LDADD = lib/libgtest.la
+test_gtest_stress_test_CXXFLAGS = $(AM_CXXFLAGS) $(PTHREAD_CFLAGS)
+test_gtest_stress_test_LDADD = $(PTHREAD_LIBS) $(PTHREAD_CFLAGS) \
+ lib/libgtest.la
TESTS += test/gtest-test-part_test
check_PROGRAMS += test/gtest-test-part_test