summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorchandlerc <chandlerc@861a406c-534a-0410-8894-cb66d6ee9925>2009-08-11 02:16:16 (GMT)
committerchandlerc <chandlerc@861a406c-534a-0410-8894-cb66d6ee9925>2009-08-11 02:16:16 (GMT)
commit888b6ebe7d8b2b1f0ee781b69126dd6981b368a5 (patch)
tree8abb790062a2bd3c176818c0a094701348c6baa2 /Makefile.am
parent5502540a5b5c5378824cd46591c2366bcf027555 (diff)
downloadgoogletest-888b6ebe7d8b2b1f0ee781b69126dd6981b368a5.zip
googletest-888b6ebe7d8b2b1f0ee781b69126dd6981b368a5.tar.gz
googletest-888b6ebe7d8b2b1f0ee781b69126dd6981b368a5.tar.bz2
Fix the 'make dist' behavior to include gtest-tuple.h and gtest-tuple.h.pump.
Missing these caused failures on platforms depending on them as well as general failures of the dedicated tests for the tuple implementation. Change was tested by running 'make distcheck' and then extracting the result to an entirely separate location (a subdirectory is insufficient, thank you Autotools) and running './configure; make check'.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e56fadf..2f7e911 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,6 +7,7 @@ EXTRA_DIST = \
CHANGES \
CONTRIBUTORS \
include/gtest/gtest-param-test.h.pump \
+ include/gtest/internal/gtest-tuple.h.pump \
include/gtest/internal/gtest-type-util.h.pump \
include/gtest/internal/gtest-param-util-generated.h.pump \
make/Makefile \
@@ -109,6 +110,7 @@ pkginclude_internal_HEADERS = \
include/gtest/internal/gtest-param-util.h \
include/gtest/internal/gtest-port.h \
include/gtest/internal/gtest-string.h \
+ include/gtest/internal/gtest-tuple.h \
include/gtest/internal/gtest-type-util.h
lib_libgtest_main_la_SOURCES = src/gtest_main.cc