summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorCarlos O'Ryan <coryan@users.noreply.github.com>2017-12-03 19:07:35 (GMT)
committerCarlos O'Ryan <coryan@users.noreply.github.com>2017-12-03 19:07:35 (GMT)
commitaea8580ecf448bc9d783181996139cae60ce44c9 (patch)
tree66fb79b90b978a99fc3e3118eefe65a68bce6a8f /Makefile.am
parent247a3d8e5e5d403f7fcacdb8ccc71e5059f15daa (diff)
downloadgoogletest-aea8580ecf448bc9d783181996139cae60ce44c9.zip
googletest-aea8580ecf448bc9d783181996139cae60ce44c9.tar.gz
googletest-aea8580ecf448bc9d783181996139cae60ce44c9.tar.bz2
Run autoconf from top-level directory.
This is part (hopefully all) of the fixes for #776. The top-level configure.ac configures googletest first and then googlemock. With this changes it is possible to embed googletest into another project that uses autoconf. For an example (though it is WIP), see the commits (and soon PR) referenced from google/protobuf#236.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..433eefe
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,14 @@
+## Process this file with automake to produce Makefile.in
+ACLOCAL_AMFLAGS = -I m4
+
+AUTOMAKE_OPTIONS = foreign
+
+# Build . before src so that our all-local and clean-local hooks kicks in at
+# the right time.
+SUBDIRS = googletest googlemock
+
+EXTRA_DIST = \
+ BUILD.bazel \
+ CMakeLists.txt \
+ README.md \
+ WORKSPACE