summaryrefslogtreecommitdiffstats
path: root/googletest/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Bodily <joshbodily@gmail.com>2017-12-12 17:36:37 (GMT)
committerGitHub <noreply@github.com>2017-12-12 17:36:37 (GMT)
commit3e2cb75446e0f56f226f0fb259e032bb4d014002 (patch)
tree4d945ff84ee3affb3187acb1fbb8ba9d300718d8 /googletest/CMakeLists.txt
parentcf85f56b2159d7c964dacb3e311163a6f9520688 (diff)
parent0fe96607d85cf3a25ac40da369db62bbee2939a5 (diff)
downloadgoogletest-3e2cb75446e0f56f226f0fb259e032bb4d014002.zip
googletest-3e2cb75446e0f56f226f0fb259e032bb4d014002.tar.gz
googletest-3e2cb75446e0f56f226f0fb259e032bb4d014002.tar.bz2
Merge branch 'master' into josh/fix_scoped_class2
Diffstat (limited to 'googletest/CMakeLists.txt')
-rw-r--r--googletest/CMakeLists.txt15
1 files changed, 10 insertions, 5 deletions
diff --git a/googletest/CMakeLists.txt b/googletest/CMakeLists.txt
index b541460..3b907fd 100644
--- a/googletest/CMakeLists.txt
+++ b/googletest/CMakeLists.txt
@@ -27,6 +27,8 @@ option(
"Build gtest with internal symbols hidden in shared libraries."
OFF)
+set(CMAKE_DEBUG_POSTFIX "d" CACHE STRING "Generate debug library name with a postfix.")
+
# Defines pre_project_set_up_hermetic_build() and set_up_hermetic_build().
include(cmake/hermetic_build.cmake OPTIONAL)
@@ -52,6 +54,10 @@ else()
endif()
cmake_minimum_required(VERSION 2.6.4)
+if (POLICY CMP0063) # Visibility
+ cmake_policy(SET CMP0063 NEW)
+endif (POLICY CMP0063)
+
if (COMMAND set_up_hermetic_build)
set_up_hermetic_build()
endif()
@@ -71,15 +77,14 @@ include_directories(
${gtest_SOURCE_DIR}/include
${gtest_SOURCE_DIR})
-# Where Google Test's libraries can be found.
-link_directories(${gtest_BINARY_DIR}/src)
-
# Summary of tuple support for Microsoft Visual Studio:
# Compiler version(MS) version(cmake) Support
# ---------- ----------- -------------- -----------------------------
# <= VS 2010 <= 10 <= 1600 Use Google Tests's own tuple.
# VS 2012 11 1700 std::tr1::tuple + _VARIADIC_MAX=10
# VS 2013 12 1800 std::tr1::tuple
+# VS 2015 14 1900 std::tuple
+# VS 2017 15 >= 1910 std::tuple
if (MSVC AND MSVC_VERSION EQUAL 1700)
add_definitions(/D _VARIADIC_MAX=10)
endif()
@@ -100,8 +105,8 @@ target_link_libraries(gtest_main gtest)
# to the targets for when we are part of a parent build (ie being pulled
# in via add_subdirectory() rather than being a standalone build).
if (DEFINED CMAKE_VERSION AND NOT "${CMAKE_VERSION}" VERSION_LESS "2.8.11")
- target_include_directories(gtest INTERFACE "${gtest_SOURCE_DIR}/include")
- target_include_directories(gtest_main INTERFACE "${gtest_SOURCE_DIR}/include")
+ target_include_directories(gtest SYSTEM INTERFACE "${gtest_SOURCE_DIR}/include")
+ target_include_directories(gtest_main SYSTEM INTERFACE "${gtest_SOURCE_DIR}/include")
endif()
########################################################################