summaryrefslogtreecommitdiffstats
path: root/googletest/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Hill <zed.three@gmail.com>2020-12-04 15:43:47 (GMT)
committerPeter Hill <zed.three@gmail.com>2020-12-04 17:21:19 (GMT)
commit2292b6d856335b6c1ee352e9cb97d7a5b193c989 (patch)
treed4533e65862e1057c716ce1ac1174c4037f81ffe /googletest/CMakeLists.txt
parent93748a946684defd1494d5585dbc912e451e83f8 (diff)
downloadgoogletest-2292b6d856335b6c1ee352e9cb97d7a5b193c989.zip
googletest-2292b6d856335b6c1ee352e9cb97d7a5b193c989.tar.gz
googletest-2292b6d856335b6c1ee352e9cb97d7a5b193c989.tar.bz2
CMake: Add namespaced ALIAS libraryrefs/pull/3155/head
Fixes #3125
Diffstat (limited to 'googletest/CMakeLists.txt')
-rw-r--r--googletest/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/googletest/CMakeLists.txt b/googletest/CMakeLists.txt
index 5e546ec..c19961e 100644
--- a/googletest/CMakeLists.txt
+++ b/googletest/CMakeLists.txt
@@ -92,10 +92,13 @@ include(cmake/internal_utils.cmake)
config_compiler_and_linker() # Defined in internal_utils.cmake.
+# Needed to set the namespace for both the export targets and the
+# alias libraries
+set(cmake_package_name GTest CACHE INTERNAL "")
+
# Create the CMake package file descriptors.
if (INSTALL_GTEST)
include(CMakePackageConfigHelpers)
- set(cmake_package_name GTest)
set(targets_export_name ${cmake_package_name}Targets CACHE INTERNAL "")
set(generated_dir "${CMAKE_CURRENT_BINARY_DIR}/generated" CACHE INTERNAL "")
set(cmake_files_install_dir "${CMAKE_INSTALL_LIBDIR}/cmake/${cmake_package_name}")