summaryrefslogtreecommitdiffstats
path: root/googletest/CMakeLists.txt
diff options
context:
space:
mode:
authorPhilip Mourdjis <philip.j.m@gmail.com>2021-12-21 16:14:03 (GMT)
committerPhilip Mourdjis <philip.j.m@gmail.com>2021-12-21 16:14:03 (GMT)
commit4745746725f45f1053b7ac8b1ac7fd5787da7b46 (patch)
tree269d4f6ce914ad19ac816d5f265b9b82f6fc7695 /googletest/CMakeLists.txt
parent9a32aee22d771387c494be2d8519fbdf46a713b2 (diff)
downloadgoogletest-4745746725f45f1053b7ac8b1ac7fd5787da7b46.zip
googletest-4745746725f45f1053b7ac8b1ac7fd5787da7b46.tar.gz
googletest-4745746725f45f1053b7ac8b1ac7fd5787da7b46.tar.bz2
link to regex on qnx in cmakerefs/pull/3713/head
Diffstat (limited to 'googletest/CMakeLists.txt')
-rw-r--r--googletest/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/googletest/CMakeLists.txt b/googletest/CMakeLists.txt
index 15b8f0c..eb03bfa 100644
--- a/googletest/CMakeLists.txt
+++ b/googletest/CMakeLists.txt
@@ -138,6 +138,9 @@ if (DEFINED CMAKE_VERSION AND NOT "${CMAKE_VERSION}" VERSION_LESS "2.8.11")
"$<BUILD_INTERFACE:${gtest_build_include_dirs}>"
"$<INSTALL_INTERFACE:$<INSTALL_PREFIX>/${CMAKE_INSTALL_INCLUDEDIR}>")
endif()
+if(CMAKE_SYSTEM_NAME MATCHES "QNX")
+ target_link_libraries(gtest PUBLIC regex)
+endif()
target_link_libraries(gtest_main PUBLIC gtest)
########################################################################