summaryrefslogtreecommitdiffstats
path: root/googletest/CMakeLists.txt
diff options
context:
space:
mode:
authorAbseil Team <absl-team@google.com>2021-08-20 21:47:35 (GMT)
committerCJ Johnson <johnsoncj@google.com>2021-08-24 16:28:58 (GMT)
commit62046339790b8fb8a37e8fde5d2edcbf4ffe2a3a (patch)
tree885c6644979906f912262d9b613ca3d6749c4c24 /googletest/CMakeLists.txt
parent2f80c2ba71c0e8922a03b9b855e5b019ad1f7064 (diff)
downloadgoogletest-62046339790b8fb8a37e8fde5d2edcbf4ffe2a3a.zip
googletest-62046339790b8fb8a37e8fde5d2edcbf4ffe2a3a.tar.gz
googletest-62046339790b8fb8a37e8fde5d2edcbf4ffe2a3a.tar.bz2
Googletest export
Bump `cmake_minimum_required` to 3.5. Delete conditional branches exclusive to older versions. Notable dependents: - github.com/grpc/grpc >= 3.5.1 - github.com/abseil/abseil-cpp >= 3.5 - github.com/googleapis/google-cloud-cpp >= 3.5 On the other hand, github.com/protocolbuffers/protobuf is >= 3.1.3, but it only depends on GoogleTest 1.10. Fixes #3523 PiperOrigin-RevId: 392073834
Diffstat (limited to 'googletest/CMakeLists.txt')
-rw-r--r--googletest/CMakeLists.txt11
1 files changed, 3 insertions, 8 deletions
diff --git a/googletest/CMakeLists.txt b/googletest/CMakeLists.txt
index abdd98b..15b8f0c 100644
--- a/googletest/CMakeLists.txt
+++ b/googletest/CMakeLists.txt
@@ -46,14 +46,9 @@ endif()
# Project version:
-if (CMAKE_VERSION VERSION_LESS 3.0)
- project(gtest CXX C)
- set(PROJECT_VERSION ${GOOGLETEST_VERSION})
-else()
- cmake_policy(SET CMP0048 NEW)
- project(gtest VERSION ${GOOGLETEST_VERSION} LANGUAGES CXX C)
-endif()
-cmake_minimum_required(VERSION 2.8.12)
+cmake_minimum_required(VERSION 3.5)
+cmake_policy(SET CMP0048 NEW)
+project(gtest VERSION ${GOOGLETEST_VERSION} LANGUAGES CXX C)
if (POLICY CMP0063) # Visibility
cmake_policy(SET CMP0063 NEW)