summaryrefslogtreecommitdiffstats
path: root/googletest/CMakeLists.txt
diff options
context:
space:
mode:
authorDeniz Bahadir <deniz@code.bahadir.email>2021-10-19 13:14:44 (GMT)
committerDeniz Bahadir <deniz@code.bahadir.email>2021-10-19 13:14:44 (GMT)
commit64f19a9fc39fb56bf643a82545cce922630091b4 (patch)
tree57a8960b2a44e299cbc164f5b7b00279f843b871 /googletest/CMakeLists.txt
parent16f637fbf4ffc3f7a01fa4eceb7906634565242f (diff)
downloadgoogletest-64f19a9fc39fb56bf643a82545cce922630091b4.zip
googletest-64f19a9fc39fb56bf643a82545cce922630091b4.tar.gz
googletest-64f19a9fc39fb56bf643a82545cce922630091b4.tar.bz2
CMake: Fix values of INTERFACE_INCLUDE_DIRECTORIES propertyrefs/pull/3617/head
Replace semicolon by `$<SEMICOLON>` in generator-expressions of target property `INTERFACE_INCLUDE_DIRECTORIES` of CMake targets `gtest`, `gtest_main`, `gmock` and `gmock_main`. Fixes: #3616 Signed-off-by: Deniz Bahadir <deniz@code.bahadir.email>
Diffstat (limited to 'googletest/CMakeLists.txt')
-rw-r--r--googletest/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/googletest/CMakeLists.txt b/googletest/CMakeLists.txt
index 15b8f0c..b03e71c 100644
--- a/googletest/CMakeLists.txt
+++ b/googletest/CMakeLists.txt
@@ -131,11 +131,12 @@ set_target_properties(gtest_main PROPERTIES VERSION ${GOOGLETEST_VERSION})
# to the targets for when we are part of a parent build (ie being pulled
# in via add_subdirectory() rather than being a standalone build).
if (DEFINED CMAKE_VERSION AND NOT "${CMAKE_VERSION}" VERSION_LESS "2.8.11")
+ string(REPLACE ";" "$<SEMICOLON>" dirs "${gtest_build_include_dirs}")
target_include_directories(gtest SYSTEM INTERFACE
- "$<BUILD_INTERFACE:${gtest_build_include_dirs}>"
+ "$<BUILD_INTERFACE:${dirs}>"
"$<INSTALL_INTERFACE:$<INSTALL_PREFIX>/${CMAKE_INSTALL_INCLUDEDIR}>")
target_include_directories(gtest_main SYSTEM INTERFACE
- "$<BUILD_INTERFACE:${gtest_build_include_dirs}>"
+ "$<BUILD_INTERFACE:${dirs}>"
"$<INSTALL_INTERFACE:$<INSTALL_PREFIX>/${CMAKE_INSTALL_INCLUDEDIR}>")
endif()
target_link_libraries(gtest_main PUBLIC gtest)