summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVailin Choi <vchoi@hdfgroup.org>2014-06-19 00:01:55 (GMT)
committerVailin Choi <vchoi@hdfgroup.org>2014-06-19 00:01:55 (GMT)
commit02eab2eb72a18fa685545ba7c7c5ac7715693d1b (patch)
treee3e544b36e7eb3900b78e0dbd0f6a574aef7ca97 /CMakeLists.txt
parent99ceb100fe1d24ccd7a01b8b3139aa5efadab4b1 (diff)
downloadhdf5-02eab2eb72a18fa685545ba7c7c5ac7715693d1b.zip
hdf5-02eab2eb72a18fa685545ba7c7c5ac7715693d1b.tar.gz
hdf5-02eab2eb72a18fa685545ba7c7c5ac7715693d1b.tar.bz2
[svn-r25328] Bring revisions #24851 - 24948 from trunk to revise_chunks.
Tested on jam, koala, ostrich, platypus.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt27
1 files changed, 17 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8d7cec2..efa9ba6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -249,7 +249,7 @@ if (NOT HDF5_EXTERNALLY_CONFIGURED)
${PROJECT_BINARY_DIR}/bin CACHE PATH "Single Directory for all static libraries."
)
set (CMAKE_Fortran_MODULE_DIRECTORY
- ${PROJECT_BINARY_DIR}/bin/fortran CACHE PATH "Single Directory for all fortran modules."
+ ${PROJECT_BINARY_DIR}/bin CACHE PATH "Single Directory for all fortran modules."
)
else (NOT HDF5_EXTERNALLY_CONFIGURED)
# if we are externally configured, but the project uses old cmake scripts
@@ -449,9 +449,9 @@ if (HDF5_DISABLE_COMPILER_WARNINGS)
string (REGEX REPLACE "(^| )([/-])W[0-9]( |$)" " " CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS}")
set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /w")
endif (MSVC)
- if (WIN32 AND NOT CYGWIN)
+ if (WIN32)
add_definitions (-D_CRT_SECURE_NO_WARNINGS)
- endif (WIN32 AND NOT CYGWIN)
+ endif (WIN32)
# Borland uses -w- to suppress warnings.
if (BORLAND)
set (HDF5_WARNINGS_BLOCKED 1)
@@ -723,27 +723,34 @@ endif (NOT HDF5_EXTERNALLY_CONFIGURED)
#-----------------------------------------------------------------------------
# Option to use threadsafe
-# Note: Currently CMake only allows configuring of threadsafe on WINDOWS.
+# Note: Currently CMake only allows configuring of threadsafe on
+# non-Cygwin WINDOWS.
#-----------------------------------------------------------------------------
-if (WIN32 AND NOT CYGWIN)
- option (HDF5_ENABLE_THREADSAFE "Enable Threadsafety" OFF)
+if (WIN32)
+ option (HDF5_ENABLE_THREADSAFE "Enable thread-safety" OFF)
if (HDF5_ENABLE_THREADSAFE)
# check for unsupported options
if (HDF5_ENABLE_PARALLEL)
- message (FATAL_ERROR " **** Parallel and Threadsafe options are mutually exclusive **** ")
+ message (FATAL_ERROR " **** parallel and thread-safety options are mutually exclusive **** ")
endif (HDF5_ENABLE_PARALLEL)
+ if (HDF5_BUILD_FORTRAN)
+ message (FATAL_ERROR " **** Fortran and thread-safety options are mutually exclusive **** ")
+ endif (HDF5_BUILD_FORTRAN)
+ if (HDF5_BUILD_CPP_LIB)
+ message (FATAL_ERROR " **** C++ and thread-safety options are mutually exclusive **** ")
+ endif (HDF5_BUILD_CPP_LIB)
set (H5_HAVE_THREADSAFE 1)
if (H5_HAVE_IOEO)
- message (STATUS " **** Windows Threads only available in WINVER>=0x600 (Vista or Windows 7) **** ")
+ message (STATUS " **** Win32 threads requires WINVER>=0x600 (Windows Vista/7/8) **** ")
set (H5_HAVE_WIN_THREADS 1)
else (H5_HAVE_IOEO)
if (NOT H5_HAVE_PTHREAD_H)
set (H5_HAVE_THREADSAFE 0)
- message (FATAL_ERROR " **** Threadsafe option requires thread library **** ")
+ message (FATAL_ERROR " **** thread-safe option requires Win32 threads or Pthreads **** ")
endif (NOT H5_HAVE_PTHREAD_H)
endif (H5_HAVE_IOEO)
endif (HDF5_ENABLE_THREADSAFE)
-endif (WIN32 AND NOT CYGWIN)
+endif (WIN32)
# -----------------------------------------------------------------------
# wrapper script variables