summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-10-29 17:15:13 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-10-29 17:15:13 (GMT)
commit0ce736c15a393e26ede6235740dadc72bb41006c (patch)
treedd81608c0a572ff6b7615799978ede239d32a390 /CMakeLists.txt
parent8c26358eca11455235df239a7e9f3a225b3141da (diff)
downloadhdf5-0ce736c15a393e26ede6235740dadc72bb41006c.zip
hdf5-0ce736c15a393e26ede6235740dadc72bb41006c.tar.gz
hdf5-0ce736c15a393e26ede6235740dadc72bb41006c.tar.bz2
HDFFV-10594, HDFFV-10332, HDFFV-9059 merge from develop
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 486e5ce..e93de59 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -776,4 +776,10 @@ endif ()
#-----------------------------------------------------------------------------
configure_file (${HDF_RESOURCES_DIR}/H5pubconf.h.in ${HDF5_BINARY_DIR}/H5pubconf.h @ONLY)
+#-----------------------------------------------------------------------------
+# Options for use by cross compiling and toolchains
+#-----------------------------------------------------------------------------
+option (HDF5_USE_PREGEN "Use pre-generated Files" OFF)
+option (HDF5_BATCH_H5DETECT "Use a batch command for running h5detect" OFF)
+
include (CMakeInstallation.cmake)