summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2022-11-09 17:22:14 (GMT)
committerGitHub <noreply@github.com>2022-11-09 17:22:14 (GMT)
commit0f30852242d906cb21d0246b3e68527f608d4d84 (patch)
tree4b1701d9155b315cad7ee1ecde250e816aedbd42 /CMakeLists.txt
parent2025d047e212b5c804ec788fe3bbbf87a93b512b (diff)
downloadhdf5-0f30852242d906cb21d0246b3e68527f608d4d84.zip
hdf5-0f30852242d906cb21d0246b3e68527f608d4d84.tar.gz
hdf5-0f30852242d906cb21d0246b3e68527f608d4d84.tar.bz2
Removes dmalloc support (#2239)
This has not been used to debug the library in a very long time. Most developers use valgrind, -fsanitize=address, or some other memory checker instead of this library. This removes: * dmalloc.h include from H5private.h * --with-dmalloc= Autotools configure option * HDF5_ENABLE_USING_DMALLOC CMake option
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 0 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1148f2d..31cae2e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -544,15 +544,6 @@ if (HDF5_ENABLE_COVERAGE)
endif ()
#-----------------------------------------------------------------------------
-# Option to indicate using dmalloc
-#-----------------------------------------------------------------------------
-# option (HDF5_ENABLE_USING_DMALLOC "Indicate that dmalloc is used" OFF)
-# if (HDF5_ENABLE_USING_DMALLOC)
-# find_package (DMALLOC)
-# set (H5_HAVE_DMALLOC DMALLOC_FOUND)
-# endif ()
-
-#-----------------------------------------------------------------------------
# Option to indicate using a memory checker
#-----------------------------------------------------------------------------
option (HDF5_ENABLE_USING_MEMCHECKER "Indicate that a memory checker is used" OFF)