summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-01-18 22:54:55 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-01-18 22:55:01 (GMT)
commit0f5ada2e0819bc107b2da0fc7d9a93bc4cd5b200 (patch)
tree1cad6f42c10dba605cdc5e51ab1d45143ef7c9ca /CMakeLists.txt
parenta2fbe6c7d835bb88645940c3f6191669d2df75eb (diff)
downloadhdf5-0f5ada2e0819bc107b2da0fc7d9a93bc4cd5b200.zip
hdf5-0f5ada2e0819bc107b2da0fc7d9a93bc4cd5b200.tar.gz
hdf5-0f5ada2e0819bc107b2da0fc7d9a93bc4cd5b200.tar.bz2
HDFFV-10385 Refactor out CMAKE_BUILD_TYPE usage
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cb01cd4..1663df4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -584,7 +584,7 @@ option (HDF5_BUILD_GENERATORS "Build Test Generators" OFF)
#-----------------------------------------------------------------------------
option (HDF5_ENABLE_TRACE "Enable API tracing capability" OFF)
mark_as_advanced (HDF5_ENABLE_TRACE)
-if (CMAKE_BUILD_TYPE MATCHES Debug)
+if (${HDF5_CFG_NAME} MATCHES "Debug")
add_definitions (-DDEBUG)
# Enable tracing of the API
if (HDF5_ENABLE_TRACE)