summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMohamad Chaarawi <chaarawi@hdfgroup.org>2014-07-10 14:36:34 (GMT)
committerMohamad Chaarawi <chaarawi@hdfgroup.org>2014-07-10 14:36:34 (GMT)
commit2700d20859e67995145677af5e3c627c19bd87b4 (patch)
tree556d0b713ebf586094d38127ecd4a02f4490e745 /CMakeLists.txt
parent0cb7846c407daef8a2c35339676078f8338cdd12 (diff)
downloadhdf5-2700d20859e67995145677af5e3c627c19bd87b4.zip
hdf5-2700d20859e67995145677af5e3c627c19bd87b4.tar.gz
hdf5-2700d20859e67995145677af5e3c627c19bd87b4.tar.bz2
[svn-r25402] Bring 25397/8 from trunk:
- remove configure checks for MPI_File_get_size and Big MPI_File_set_size as they are supported by MPIO implementations today. - fix bug in t_mpi.c (HDFFV-8856) tested with h5committest.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dcf5d7c..9667dcf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -643,8 +643,6 @@ if (HDF5_ENABLE_PARALLEL)
# MPI checks, only do these if MPI_C_FOUND is true, otherwise they always fail
# and once set, they are cached as false and not regenerated
set (CMAKE_REQUIRED_LIBRARIES "${MPI_C_LIBRARIES}" )
- CHECK_FUNCTION_EXISTS (MPI_File_get_size H5_HAVE_MPI_GET_SIZE)
- set (H5_MPI_FILE_SET_SIZE_BIG 1)
# Used by Fortran + MPI
CHECK_SYMBOL_EXISTS (MPI_Comm_c2f "${MPI_C_INCLUDE_PATH}/mpi.h" H5_HAVE_MPI_MULTI_LANG_Comm)
CHECK_SYMBOL_EXISTS (MPI_Info_c2f "${MPI_C_INCLUDE_PATH}/mpi.h" H5_HAVE_MPI_MULTI_LANG_Info)