summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2023-10-19 13:01:02 (GMT)
committerGitHub <noreply@github.com>2023-10-19 13:01:02 (GMT)
commit29c1c02300c00deb2584e672041b3775b11aaf87 (patch)
treeea489b5b4fb7919801f3b739fbbd66a2132e5386 /CMakeLists.txt
parentebd3744407cf835fcca0170814517da09f62d814 (diff)
downloadhdf5-29c1c02300c00deb2584e672041b3775b11aaf87.zip
hdf5-29c1c02300c00deb2584e672041b3775b11aaf87.tar.gz
hdf5-29c1c02300c00deb2584e672041b3775b11aaf87.tar.bz2
Some corrections and fix for plugins (#3712)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6aa467d..5b76afe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -413,6 +413,13 @@ set (HDF5_PACKAGE_URL "http://www.hdfgroup.org")
set (HDF5_PACKAGE_BUGREPORT "help@hdfgroup.org")
#-----------------------------------------------------------------------------
+# Set variables needed for installation
+#-----------------------------------------------------------------------------
+set (HDF5_VERSION_STRING ${HDF5_PACKAGE_VERSION})
+set (HDF5_VERSION_MAJOR ${HDF5_PACKAGE_VERSION_MAJOR})
+set (HDF5_VERSION_MINOR ${HDF5_PACKAGE_VERSION_MINOR})
+
+#-----------------------------------------------------------------------------
# Include some macros for reusable code
#-----------------------------------------------------------------------------
include (${HDF_RESOURCES_DIR}/HDFMacros.cmake)