summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2022-06-12 04:06:49 (GMT)
committerGitHub <noreply@github.com>2022-06-12 04:06:49 (GMT)
commit2a147be72f29bbe5077bdb7b21b74fc5d24f1b44 (patch)
treea9549d2f2c1ed4f0635f47d334005cbc0ff092b4 /CMakeLists.txt
parent4466a30825eda620a00e5d8fac35ecf765296aad (diff)
downloadhdf5-2a147be72f29bbe5077bdb7b21b74fc5d24f1b44.zip
hdf5-2a147be72f29bbe5077bdb7b21b74fc5d24f1b44.tar.gz
hdf5-2a147be72f29bbe5077bdb7b21b74fc5d24f1b44.tar.bz2
Hdf5 1 12 sync (#1794)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 18b7b87..6ef148e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,10 +2,13 @@ cmake_minimum_required (VERSION 3.12)
project (HDF5 C)
if (POLICY CMP0074)
+ # find_package() uses <PackageName>_ROOT variables.
cmake_policy (SET CMP0074 NEW)
endif ()
if (POLICY CMP0083)
+ # To control generation of Position Independent Executable (PIE) or not,
+ # some flags are required at link time.
cmake_policy (SET CMP0083 NEW)
endif ()