summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2023-12-22 21:17:05 (GMT)
committerGitHub <noreply@github.com>2023-12-22 21:17:05 (GMT)
commit366f2d94a3f5ee20287de8062a2a2c895e9eb856 (patch)
tree723c29f3a08b73b1e69bd824c392960e4bab3bd9 /CMakeLists.txt
parent11e15aeed1b82201ea0805dcef5bfce3ac02b9cb (diff)
downloadhdf5-366f2d94a3f5ee20287de8062a2a2c895e9eb856.zip
hdf5-366f2d94a3f5ee20287de8062a2a2c895e9eb856.tar.gz
hdf5-366f2d94a3f5ee20287de8062a2a2c895e9eb856.tar.bz2
Add CMake api checks to test the new Examples folder. (#3907)
* Fix missing build-mode value * Use 110 version file only for the 1.10 library * Fix H5_LIBVER_DIR variable * Disable 1.6 API tests for now.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 13 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e73b7f9..b45c63a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -418,6 +418,7 @@ set (HDF5_PACKAGE_BUGREPORT "help@hdfgroup.org")
set (HDF5_VERSION_STRING ${HDF5_PACKAGE_VERSION})
set (HDF5_VERSION_MAJOR ${HDF5_PACKAGE_VERSION_MAJOR})
set (HDF5_VERSION_MINOR ${HDF5_PACKAGE_VERSION_MINOR})
+set (H5_LIBVER_DIR ${H5_VERS_MAJOR}${H5_VERS_MINOR})
#-----------------------------------------------------------------------------
# Include some macros for reusable code
@@ -1026,15 +1027,20 @@ endif ()
#-----------------------------------------------------------------------------
# Include filter plugins
#-----------------------------------------------------------------------------
-include (CMakePlugins.cmake)
+if (${H5_LIBVER_DIR} EQUAL 16 OR DEFAULT_API_VERSION MATCHES "v16")
+ set (HDF5_ENABLE_PLUGIN_SUPPORT OFF CACHE BOOL "" FORCE)
+ message (VERBOSE "Filter PLUGINs cannot be used with 1.6 API")
+else ()
+ include (CMakePlugins.cmake)
-if (HDF5_PACKAGE_EXTLIBS AND NOT HDF5_NO_PACKAGES)
- if (HDF5_ENABLE_PLUGIN_SUPPORT AND PLUGIN_FOUND)
- PACKAGE_PLUGIN_LIBRARY (${HDF5_ALLOW_EXTERNAL_SUPPORT})
-# option (HDF5_TEST_PLUGIN "Execute plugin tests" ON)
-# mark_as_advanced (HDF5_TEST_PLUGIN)
+ if (HDF5_PACKAGE_EXTLIBS AND NOT HDF5_NO_PACKAGES)
+ if (HDF5_ENABLE_PLUGIN_SUPPORT AND PLUGIN_FOUND)
+ PACKAGE_PLUGIN_LIBRARY (${HDF5_ALLOW_EXTERNAL_SUPPORT})
+# option (HDF5_TEST_PLUGIN "Execute plugin tests" ON)
+# mark_as_advanced (HDF5_TEST_PLUGIN)
-# TEST_PLUGIN_LIBRARY ()
+# TEST_PLUGIN_LIBRARY ()
+ endif ()
endif ()
endif ()