summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2020-11-12 16:50:00 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2020-11-12 16:50:00 (GMT)
commit46bc76ab634ed418c51c4dc50741533027a9cec9 (patch)
treea61d330e19e07747dcaf3bc9eaa35beb6855886c /CMakeLists.txt
parentaaca30285228aa56d100734a667db5d4e7942087 (diff)
downloadhdf5-46bc76ab634ed418c51c4dc50741533027a9cec9.zip
hdf5-46bc76ab634ed418c51c4dc50741533027a9cec9.tar.gz
hdf5-46bc76ab634ed418c51c4dc50741533027a9cec9.tar.bz2
Correct TARGET variable and CMake config file location
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 8 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 704e89a..1e8664d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -572,12 +572,15 @@ endif ()
# Certain systems may add /Debug or /Release to output paths
# and we need to call the executable from inside the CMake configuration
#-----------------------------------------------------------------------------
-set (EXE_EXT "")
-if (WIN32 OR MINGW)
- set (EXE_EXT ".exe")
- add_compile_definitions (_BIND_TO_CURRENT_VCLIBS_VERSION=1 _CRT_SECURE_NO_WARNINGS _CONSOLE)
+if (WIN32)
+ add_compile_definitions (_CRT_SECURE_NO_WARNINGS)
+ if (MSVC)
+ add_compile_definitions (_BIND_TO_CURRENT_VCLIBS_VERSION=1 _CONSOLE)
+ endif ()
endif ()
+option (HDF5_MINGW_STATIC_GCC_LIBS "Statically link libgcc/libstdc++" OFF)
+
if (MSVC)
set (CMAKE_MFC_FLAG 0)
set (WIN_COMPILE_FLAGS "")
@@ -766,7 +769,7 @@ endif ()
option (HDF5_ENABLE_THREADSAFE "Enable thread-safety" OFF)
if (HDF5_ENABLE_THREADSAFE)
# check for unsupported options
- if (WIN32 OR MINGW)
+ if (WIN32)
message (STATUS " **** thread-safety option not supported with static library **** ")
message (STATUS " **** thread-safety option will not be used building static library **** ")
endif ()