summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2019-08-12 16:29:22 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2019-08-12 16:29:22 (GMT)
commit57141e58885f3b070f5fd9c612dc5eb90ef488bc (patch)
tree83f4ab8755947d947f6ba34bd2e61e44fc9d107d /CMakeLists.txt
parent8ea498c8569940b14f576eb0ae137c2e8824c304 (diff)
downloadhdf5-57141e58885f3b070f5fd9c612dc5eb90ef488bc.zip
hdf5-57141e58885f3b070f5fd9c612dc5eb90ef488bc.tar.gz
hdf5-57141e58885f3b070f5fd9c612dc5eb90ef488bc.tar.bz2
Fix API version option
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 85b657d..2c46d95 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -510,7 +510,10 @@ endif ()
#-----------------------------------------------------------------------------
# Option to use 1.8.x API
#-----------------------------------------------------------------------------
-option (HDF5_USE_18_API_DEFAULT "Use the HDF5 1.8.x API by default" ON)
+option (HDF5_USE_18_API_DEFAULT "Use the HDF5 1.8.x API by default" OFF)
+if (NOT HDF5_USE_16_API_DEFAULT AND NOT HDF5_USE_18_API_DEFAULT)
+ set (HDF5_USE_18_API_DEFAULT ON)
+endif ()
set (H5_USE_18_API_DEFAULT 0)
if (HDF5_USE_18_API_DEFAULT)
set (H5_USE_18_API_DEFAULT 1)