summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2023-10-19 21:58:33 (GMT)
committerGitHub <noreply@github.com>2023-10-19 21:58:33 (GMT)
commit5844f498b03c9da5eb99c6665f4a8ff4663b190f (patch)
treed1f0e2d676ff06300a1de769c2afcc929f734484 /CMakeLists.txt
parent5672fd817732e6a7fda3886010452bc7c8598cf8 (diff)
downloadhdf5-5844f498b03c9da5eb99c6665f4a8ff4663b190f.zip
hdf5-5844f498b03c9da5eb99c6665f4a8ff4663b190f.tar.gz
hdf5-5844f498b03c9da5eb99c6665f4a8ff4663b190f.tar.bz2
Add an option to disable doxygen warn as error (#3708)
Add for both CMake and the Autotools * HDF5_ENABLE_DOXY_WARNINGS: ON/OFF (Default: ON) * --enable-doxygen-errors: enable/disable (Default: enable) The default will fail compile if the doxygen parsing generates warnings. The option can be disabled if certain versions of doxygen have parsing issues. i.e. 1.9.5, 1.9.8. Fixes #3398
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5b76afe..c440c58 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -959,6 +959,13 @@ if (HDF5_BUILD_DOC AND EXISTS "${HDF5_DOXYGEN_DIR}" AND IS_DIRECTORY "${HDF5_DOX
# check if Doxygen is installed
find_package(Doxygen)
if (DOXYGEN_FOUND)
+ option (HDF5_ENABLE_DOXY_WARNINGS "Enable fail if doxygen parsing has warnings." ON)
+ mark_as_advanced (HDF5_ENABLE_DOXY_WARNINGS)
+ if (HDF5_ENABLE_DOXY_WARNINGS)
+ set (HDF5_DOXY_WARNINGS "FAIL_ON_WARNINGS")
+ else ()
+ set (HDF5_DOXY_WARNINGS "NO")
+ endif ()
message(STATUS "Doxygen version: ${DOXYGEN_VERSION}")
add_subdirectory (doxygen)
else ()