summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2023-10-04 16:10:34 (GMT)
committerGitHub <noreply@github.com>2023-10-04 16:10:34 (GMT)
commit7b18845e9c24cc0d910fa082d3f5c7c92797396d (patch)
treeb9a6ed968b3ec24ff1681915037703ed00212a97 /CMakeLists.txt
parent51ff48b8873d584811f4cad83c19f1edf484b7e4 (diff)
downloadhdf5-7b18845e9c24cc0d910fa082d3f5c7c92797396d.zip
hdf5-7b18845e9c24cc0d910fa082d3f5c7c92797396d.tar.gz
hdf5-7b18845e9c24cc0d910fa082d3f5c7c92797396d.tar.bz2
Disable static + thread-safe on Windows w/ CMake (#3622) (#3630)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ebd45c8..da12dd3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -863,8 +863,9 @@ option (HDF5_ENABLE_THREADSAFE "Enable thread-safety" OFF)
if (HDF5_ENABLE_THREADSAFE)
# check for unsupported options
if (WIN32)
- message (VERBOSE " **** thread-safety option not supported with static library **** ")
- message (VERBOSE " **** thread-safety option will not be used building static library **** ")
+ if (BUILD_STATIC_LIBS)
+ message (FATAL_ERROR " **** thread-safety option not supported with static library **** ")
+ endif ()
endif ()
if (HDF5_BUILD_FORTRAN)
if (NOT ALLOW_UNSUPPORTED)