summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2023-10-19 22:26:39 (GMT)
committerGitHub <noreply@github.com>2023-10-19 22:26:39 (GMT)
commit847cb427cb7100be88d78e954a02a70b10d0f5c4 (patch)
treed3822fd44413998badf4063fb5a752e55a883c87 /CMakeLists.txt
parentce864f6040c65df7909931c06ac72c18a8ce9ff7 (diff)
downloadhdf5-847cb427cb7100be88d78e954a02a70b10d0f5c4.zip
hdf5-847cb427cb7100be88d78e954a02a70b10d0f5c4.tar.gz
hdf5-847cb427cb7100be88d78e954a02a70b10d0f5c4.tar.bz2
GH issue 3398 - option to disable doxygen warn as error (#3709)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 09fee70..0dd250c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -945,6 +945,13 @@ if (HDF5_BUILD_DOC AND EXISTS "${HDF5_DOXYGEN_DIR}" AND IS_DIRECTORY "${HDF5_DOX
# check if Doxygen is installed
find_package(Doxygen)
if (DOXYGEN_FOUND)
+ option (HDF5_ENABLE_DOXY_WARNINGS "Enable fail if doxygen parsing has warnings." ON)
+ mark_as_advanced (HDF5_ENABLE_DOXY_WARNINGS)
+ if (HDF5_ENABLE_DOXY_WARNINGS)
+ set (HDF5_DOXY_WARNINGS "FAIL_ON_WARNINGS")
+ else ()
+ set (HDF5_DOXY_WARNINGS "NO")
+ endif ()
message(STATUS "Doxygen version: ${DOXYGEN_VERSION}")
add_subdirectory (doxygen)
else ()