summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2010-10-29 15:43:31 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2010-10-29 15:43:31 (GMT)
commit8e04644abdc73446e85bac72bcced171a927b1f0 (patch)
treef9c3f389ea4a61030c3c99d20e27882389d0542a /CMakeLists.txt
parent059db7a4f22613bffacc60b873fa8c276d6a7cbf (diff)
downloadhdf5-8e04644abdc73446e85bac72bcced171a927b1f0.zip
hdf5-8e04644abdc73446e85bac72bcced171a927b1f0.tar.gz
hdf5-8e04644abdc73446e85bac72bcced171a927b1f0.tar.bz2
[svn-r19698] Description:
Bring r19668:19697 from trunk to revise_chunks branch. Tested on: FreeBSD/32 6.3 (duty) in debug mode FreeBSD/64 6.3 (liberty) w/C++ & FORTRAN, in debug mode Linux/32 2.6 (jam) w/PGI compilers, w/default API=1.8.x, w/C++ & FORTRAN, w/threadsafe, in debug mode Linux/64-amd64 2.6 (amani) w/Intel compilers, w/default API=1.6.x, w/C++ & FORTRAN, in production mode Solaris/32 2.10 (linew) w/deprecated symbols disabled, w/C++ & FORTRAN, w/szip filter, w/threadsafe, in production mode Linux/PPC 2.6 (heiwa) w/C++ & FORTRAN, w/threadsafe, in debug mode Linux/64-ia64 2.6 (cobalt) w/Intel compilers, w/C++ & FORTRAN, in production mode Linux/64-amd64 2.6 (abe) w/parallel, w/FORTRAN, in debug mode
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 10503ac..e4ae935 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -398,8 +398,7 @@ IF (HDF5_ENABLE_PARALLEL)
SET (H5_HAVE_PARALLEL 1)
# MPI checks, only do these if MPI_FOUND is true, otherwise they always fail
# and once set, they are cached as false and not regenerated
- SET (CMAKE_REQUIRED_INCLUDES "${MPI_INCLUDE_PATH}/mpi.h" )
- SET (CMAKE_REQUIRED_LIBRARIES "${MPI_LIBRARY}" )
+ SET (CMAKE_REQUIRED_LIBRARIES "${MPI_LIBRARY};${MPI_EXTRA_LIBRARY}" )
CHECK_FUNCTION_EXISTS (MPI_File_get_size H5_HAVE_MPI_GET_SIZE)
# Used by Fortran + MPI
CHECK_SYMBOL_EXISTS (MPI_Comm_c2f "${MPI_INCLUDE_PATH}/mpi.h" H5_HAVE_MPI_MULTI_LANG_Comm)