summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2020-02-23 17:55:47 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2020-02-23 17:55:47 (GMT)
commit9ed096fb39e2e1851ed27f292a97baa45f306d01 (patch)
treec5f900a85177dd35c1c586615654249ab41bb0cb /CMakeLists.txt
parenta6706e3a7850aa3095e8c3530417cfdcf7236e96 (diff)
downloadhdf5-9ed096fb39e2e1851ed27f292a97baa45f306d01.zip
hdf5-9ed096fb39e2e1851ed27f292a97baa45f306d01.tar.gz
hdf5-9ed096fb39e2e1851ed27f292a97baa45f306d01.tar.bz2
Merge changes from develop mostly cmake 3.12 minimum version
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt29
1 files changed, 16 insertions, 13 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f28fdef..b10eb8d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,10 +1,14 @@
-cmake_minimum_required (VERSION 3.10)
+cmake_minimum_required (VERSION 3.12)
project (HDF5 C)
if (POLICY CMP0074)
cmake_policy (SET CMP0074 NEW)
endif ()
+if (POLICY CMP0083)
+ cmake_policy (SET CMP0083 NEW)
+endif ()
+
#-----------------------------------------------------------------------------
# Instructions for use : Normal Build
#
@@ -34,9 +38,14 @@ endif ()
# CMake version 3.14 added option --ignore-eol to compare files
# cmake -E compare_files --ignore-eol file1 file2
-#if(CMAKE_VERSION VERSION_LESS "3.14.0" AND WIN32)
-# MESSAGE(FATAL_ERROR "Windows builds requires a minimum of CMake 3.14")
-#endif()
+set (CMAKE_IGNORE_EOL "--ignore-eol")
+if (CMAKE_VERSION VERSION_LESS "3.14.0")
+ set (CMAKE_IGNORE_EOL "")
+ if (WIN32)
+ message (FATAL_ERROR "Windows builds requires a minimum of CMake 3.14")
+ endif()
+else ()
+endif ()
#-----------------------------------------------------------------------------
# Instructions for use : Sub-Project Build
@@ -555,9 +564,9 @@ endif ()
set (EXE_EXT "")
if (WIN32 OR MINGW)
set (EXE_EXT ".exe")
- add_definitions (-D_BIND_TO_CURRENT_VCLIBS_VERSION=1)
- add_definitions (-D_CRT_SECURE_NO_WARNINGS)
- add_definitions (-D_CONSOLE)
+ add_compile_definitions (-D_BIND_TO_CURRENT_VCLIBS_VERSION=1)
+ add_compile_definitions (-D_CRT_SECURE_NO_WARNINGS)
+ add_compile_definitions (-D_CONSOLE)
endif ()
if (MSVC)
@@ -946,12 +955,6 @@ if (EXISTS "${HDF5_SOURCE_DIR}/fortran" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/for
include (${HDF_RESOURCES_EXT_DIR}/HDFUseFortran.cmake)
message (STATUS "Fortran compiler ID is ${CMAKE_Fortran_COMPILER_ID}")
- # Building with PGI requires CMake 3.3 or greater because previous versions
- # of CMake add the wrong compiler flag for the PGI Fortran compiler.
- if (CMAKE_Fortran_COMPILER_ID MATCHES "PGI" AND CMAKE_VERSION VERSION_LESS "3.3")
- message (FATAL_ERROR " **** PGI FORTRAN REQUIRES CMAKE VERSION 3.3 OR GREATER **** ")
- endif ()
-
include (${HDF_RESOURCES_DIR}/HDF5UseFortran.cmake)
set (LINK_Fortran_LIBS ${LINK_LIBS})