summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2024-01-04 18:06:36 (GMT)
committerGitHub <noreply@github.com>2024-01-04 18:06:36 (GMT)
commita00d62f77a715b0b4b862a594d1d85f4a0e5296c (patch)
treea71df5a1d896a4db7afa61cf3632768ae960c4fd /CMakeLists.txt
parentde3ee47a44ffa7876c1e823eef6045f7fde8e165 (diff)
downloadhdf5-a00d62f77a715b0b4b862a594d1d85f4a0e5296c.zip
hdf5-a00d62f77a715b0b4b862a594d1d85f4a0e5296c.tar.gz
hdf5-a00d62f77a715b0b4b862a594d1d85f4a0e5296c.tar.bz2
Use props for includes and remove global includes (#3921)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b45c63a..803dbff 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -462,7 +462,8 @@ set (CMAKE_INCLUDE_CURRENT_DIR_IN_INTERFACE ON)
# Include directories in the source or build tree should come before other
# directories to prioritize headers in the sources over installed ones.
#-----------------------------------------------------------------------------
-set(CMAKE_INCLUDE_DIRECTORIES_PROJECT_BEFORE ON)
+set (CMAKE_INCLUDE_DIRECTORIES_PROJECT_BEFORE ON)
+set (HDF5_COMP_INCLUDE_DIRECTORIES)
#-----------------------------------------------------------------------------
# Mac OS X Options