summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@lbl.gov>2020-08-16 16:49:15 (GMT)
committerQuincey Koziol <koziol@lbl.gov>2020-08-16 16:49:15 (GMT)
commita20bf599b682bfa0a91d571a922973e0c53b524a (patch)
tree10bc7fc1f4d90fa6a78a70c594e6cc0b4527fcea /CMakeLists.txt
parent83c861f32793ea6aaefbeaac870f46fdb09a3412 (diff)
parentc81f01d5dcf7c010e92d3aaca990a14c8bc6961c (diff)
downloadhdf5-a20bf599b682bfa0a91d571a922973e0c53b524a.zip
hdf5-a20bf599b682bfa0a91d571a922973e0c53b524a.tar.gz
hdf5-a20bf599b682bfa0a91d571a922973e0c53b524a.tar.bz2
Merge remote-tracking branch 'origin/develop' into pio_update
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 16 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7d6e7a2..ac291fa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -777,28 +777,28 @@ if (HDF5_ENABLE_THREADSAFE)
endif ()
if (HDF5_ENABLE_PARALLEL)
if (NOT ALLOW_UNSUPPORTED)
- message (FATAL_ERROR " **** parallel and thread-safety options are not supported **** ")
+ message (FATAL_ERROR " **** parallel and thread-safety options are not supported, override with ALLOW_UNSUPPORTED option **** ")
else ()
message (STATUS " **** Allowing unsupported parallel and thread-safety options **** ")
endif ()
endif ()
if (HDF5_BUILD_FORTRAN)
if (NOT ALLOW_UNSUPPORTED)
- message (FATAL_ERROR " **** Fortran and thread-safety options are not supported **** ")
+ message (FATAL_ERROR " **** Fortran and thread-safety options are not supported, override with ALLOW_UNSUPPORTED option **** ")
else ()
message (STATUS " **** Allowing unsupported Fortran and thread-safety options **** ")
endif ()
endif ()
if (HDF5_BUILD_CPP_LIB)
if (NOT ALLOW_UNSUPPORTED)
- message (FATAL_ERROR " **** C++ and thread-safety options are not supported **** ")
+ message (FATAL_ERROR " **** C++ and thread-safety options are not supported, override with ALLOW_UNSUPPORTED option **** ")
else ()
message (STATUS " **** Allowing unsupported C++ and thread-safety options **** ")
endif ()
endif ()
if (HDF5_BUILD_HL_LIB)
if (NOT ALLOW_UNSUPPORTED)
- message (FATAL_ERROR " **** HL and thread-safety options are not supported **** ")
+ message (FATAL_ERROR " **** HL and thread-safety options are not supported, override with ALLOW_UNSUPPORTED option **** ")
else ()
message (STATUS " **** Allowing unsupported HL and thread-safety options **** ")
endif ()
@@ -995,6 +995,17 @@ if (EXISTS "${HDF5_SOURCE_DIR}/fortran" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/for
endif ()
endif ()
+ #option (HDF5_INSTALL_MOD_FORTRAN "Copy FORTRAN mod files to include directory (NO SHARED STATIC)" "NO")
+ set (HDF5_INSTALL_MOD_FORTRAN "SHARED" CACHE STRING "Copy FORTRAN mod files to include directory (NO SHARED STATIC)")
+ set_property (CACHE HDF5_INSTALL_MOD_FORTRAN PROPERTY STRINGS NO SHARED STATIC)
+ if (NOT HDF5_INSTALL_MOD_FORTRAN MATCHES "NO")
+ if (NOT BUILD_SHARED_LIBS AND BUILD_STATIC_LIBS)
+ set (HDF5_INSTALL_MOD_FORTRAN "STATIC")
+ elseif (BUILD_SHARED_LIBS AND NOT BUILD_STATIC_LIBS)
+ set (HDF5_INSTALL_MOD_FORTRAN "SHARED")
+ endif ()
+ endif ()
+
add_subdirectory (fortran)
if (HDF5_BUILD_HL_LIB)
if (EXISTS "${HDF5_SOURCE_DIR}/hl/fortran" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/hl/fortran")
@@ -1014,7 +1025,7 @@ if (EXISTS "${HDF5_SOURCE_DIR}/c++" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/c++")
# check for unsupported options
if (HDF5_ENABLE_PARALLEL)
if (NOT ALLOW_UNSUPPORTED)
- message (FATAL_ERROR " **** Parallel and C++ options are mutually exclusive **** ")
+ message (FATAL_ERROR " **** Parallel and C++ options are mutually exclusive, override with ALLOW_UNSUPPORTED option **** ")
else ()
message (STATUS " **** Allowing unsupported Parallel and C++ options **** ")
endif ()