summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2020-12-15 23:12:47 (GMT)
committerGitHub <noreply@github.com>2020-12-15 23:12:47 (GMT)
commitae69e6dd45025785fa3caa882bebf7efe723fcd5 (patch)
tree668f592c408307cef45369894cbc04d42758c9e9 /CMakeLists.txt
parentd673ee0cdd826100f6c914ea0851d742699ed740 (diff)
downloadhdf5-ae69e6dd45025785fa3caa882bebf7efe723fcd5.zip
hdf5-ae69e6dd45025785fa3caa882bebf7efe723fcd5.tar.gz
hdf5-ae69e6dd45025785fa3caa882bebf7efe723fcd5.tar.bz2
OESS-98 fix tools test for plugins - HDF5 1 12 (#178)
* merge updates from develop * remove extension on command * Run autogen before chkmanifest * Update release text files and whitespace cleanup * Update list * OESS-98 Update plugin build option * OESS-98 fix tools test for plugins * Fix conflict
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index afa034e..4f86832 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -973,6 +973,21 @@ if (EXISTS "${HDF5_SOURCE_DIR}/tools" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/tools
endif ()
#-----------------------------------------------------------------------------
+# Include filter plugins
+#-----------------------------------------------------------------------------
+include (CMakePlugins.cmake)
+
+if (HDF5_PACKAGE_EXTLIBS AND NOT HDF5_NO_PACKAGES)
+ if (HDF5_ENABLE_PLUGIN_SUPPORT AND PLUGIN_FOUND)
+ PACKAGE_PLUGIN_LIBRARY (${HDF5_ALLOW_EXTERNAL_SUPPORT})
+# option (HDF5_TEST_PLUGIN "Execute plugin tests" ON)
+# mark_as_advanced (HDF5_TEST_PLUGIN)
+
+# TEST_PLUGIN_LIBRARY ()
+ endif ()
+endif ()
+
+#-----------------------------------------------------------------------------
# Option to build examples
#-----------------------------------------------------------------------------
if (EXISTS "${HDF5_SOURCE_DIR}/examples" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/examples")