summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2018-10-15 16:04:17 (GMT)
committerLarry Knox <lrknox@hdfgroup.org>2018-10-15 16:04:17 (GMT)
commitf3f29dc7df5f3cc41a5e9462d8c415e540cda3d6 (patch)
tree98e19e98333de2fcdf6f8f9a777528dde879733d /CMakeLists.txt
parent6569f208b8f39ace9e442e94ab110bec94c67d37 (diff)
parent545c5fb2a957c245f283c6db5c429b7b89cda622 (diff)
downloadhdf5-f3f29dc7df5f3cc41a5e9462d8c415e540cda3d6.zip
hdf5-f3f29dc7df5f3cc41a5e9462d8c415e540cda3d6.tar.gz
hdf5-f3f29dc7df5f3cc41a5e9462d8c415e540cda3d6.tar.bz2
Merge branch 'hdf5_1_10_4' into 1.10/masterhdf5-1_10_4
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a99ba33..24bb83d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -46,6 +46,9 @@ endif ()
# dependencies of the HDF5 libs may be 'incomplete', add additional
# dependencies to this variable so that external projects pick them up
#
+#option (HDF5_EXTERNAL_LIB_PREFIX "Use prefix for custom library naming." "")
+set (HDF5_EXTERNAL_LIB_PREFIX "" CACHE STRING "Use prefix for custom library naming.")
+mark_as_advanced (HDF5_EXTERNAL_LIB_PREFIX)
# HDF5_EXTERNAL_LIB_PREFIX :
# If the parent project needs to install hdf libraries, but avoid
# name conflicts with system versions, then a prefix may be added
@@ -548,11 +551,11 @@ else ()
endif ()
include (${HDF_RESOURCES_DIR}/HDFCompilerFlags.cmake)
+set (CMAKE_MODULE_PATH ${HDF_RESOURCES_DIR} ${HDF_RESOURCES_EXT_DIR} ${CMAKE_MODULE_PATH})
#-----------------------------------------------------------------------------
# Option to Enable MPI Parallel
#-----------------------------------------------------------------------------
-set (CMAKE_MODULE_PATH ${HDF_RESOURCES_DIR} ${HDF_RESOURCES_EXT_DIR} ${CMAKE_MODULE_PATH})
option (HDF5_ENABLE_PARALLEL "Enable parallel build (requires MPI)" OFF)
if (HDF5_ENABLE_PARALLEL)
find_package(MPI REQUIRED)
@@ -586,7 +589,7 @@ if (HDF5_ENABLE_PARALLEL)
set (LARGE_PARALLEL_IO OFF)
endif ()
else ()
- message (STATUS "Parallel libraries not found")
+ message (FATAL_ERROR "Parallel libraries not found")
endif ()
endif ()