summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2020-12-16 17:59:51 (GMT)
committerGitHub <noreply@github.com>2020-12-16 17:59:51 (GMT)
commitfaf3a2fae0c0c7afdc184c61abc918a03e916f68 (patch)
treee6c8b3eef6e2e7093c7baa5f65f7e47361c994c9 /CMakeLists.txt
parentaffbead81a20712920bfe350eb90b0a4bb754ebf (diff)
downloadhdf5-faf3a2fae0c0c7afdc184c61abc918a03e916f68.zip
hdf5-faf3a2fae0c0c7afdc184c61abc918a03e916f68.tar.gz
hdf5-faf3a2fae0c0c7afdc184c61abc918a03e916f68.tar.bz2
OESS-98 convert plugin option to FetchContent, add tests (#155)
* OESS-98 convert plugin option to FetchContent, add tests * Fixes for pkcfg files because of plugin option * Update other test machines * OESS-98 fix tools test for plugins * HDFFV-10865 performance improvement for java array
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt31
1 files changed, 15 insertions, 16 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f404c90..b65bdf2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -855,17 +855,6 @@ endif ()
#-----------------------------------------------------------------------------
add_subdirectory (src)
-#-----------------------------------------------------------------------------
-# Include filter plugins
-#-----------------------------------------------------------------------------
-include (CMakePlugins.cmake)
-
-if (HDF5_PACKAGE_EXTLIBS AND NOT HDF5_NO_PACKAGES)
- if (HDF5_ENABLE_PLUGIN_SUPPORT AND PLUGIN_FOUND)
- PACKAGE_PLUGIN_LIBRARY (${HDF5_ALLOW_EXTERNAL_SUPPORT})
- endif ()
-endif ()
-
if (HDF5_ALLOW_EXTERNAL_SUPPORT MATCHES "GIT" OR HDF5_ALLOW_EXTERNAL_SUPPORT MATCHES "TGZ")
if (ZLIB_FOUND AND ZLIB_USE_EXTERNAL)
if (NOT ONLY_SHARED_LIBS)
@@ -883,11 +872,6 @@ if (HDF5_ALLOW_EXTERNAL_SUPPORT MATCHES "GIT" OR HDF5_ALLOW_EXTERNAL_SUPPORT MAT
add_dependencies (${HDF5_LIBSH_TARGET} SZIP)
endif ()
endif ()
- if (PLUGIN_FOUND AND PLUGIN_USE_EXTERNAL)
- if (BUILD_SHARED_LIBS)
- add_dependencies (PLUGIN ${HDF5_LIBSH_TARGET})
- endif ()
- endif ()
endif ()
#-----------------------------------------------------------------------------
@@ -985,6 +969,21 @@ if (EXISTS "${HDF5_SOURCE_DIR}/tools" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/tools
endif ()
#-----------------------------------------------------------------------------
+# Include filter plugins
+#-----------------------------------------------------------------------------
+include (CMakePlugins.cmake)
+
+if (HDF5_PACKAGE_EXTLIBS AND NOT HDF5_NO_PACKAGES)
+ if (HDF5_ENABLE_PLUGIN_SUPPORT AND PLUGIN_FOUND)
+ PACKAGE_PLUGIN_LIBRARY (${HDF5_ALLOW_EXTERNAL_SUPPORT})
+# option (HDF5_TEST_PLUGIN "Execute plugin tests" ON)
+# mark_as_advanced (HDF5_TEST_PLUGIN)
+
+# TEST_PLUGIN_LIBRARY ()
+ endif ()
+endif ()
+
+#-----------------------------------------------------------------------------
# Option to build examples
#-----------------------------------------------------------------------------
if (EXISTS "${HDF5_SOURCE_DIR}/examples" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/examples")