summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2024-02-08 13:58:08 (GMT)
committerLarry Knox <lrknox@hdfgroup.org>2024-02-14 22:08:37 (GMT)
commitfed6e095e517d1c1b0a82ec7f6b5a4dc04f523e8 (patch)
tree651860dc59e8dc94b978660a29149fa4fd098746 /CMakeLists.txt
parent3cd2b678bf1f971d107a55240f9a12fa8e1a8df5 (diff)
downloadhdf5-fed6e095e517d1c1b0a82ec7f6b5a4dc04f523e8.zip
hdf5-fed6e095e517d1c1b0a82ec7f6b5a4dc04f523e8.tar.gz
hdf5-fed6e095e517d1c1b0a82ec7f6b5a4dc04f523e8.tar.bz2
Add abi-complience check and upload to releases (#3996)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7a35aa5..2446958 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1155,6 +1155,11 @@ if (EXISTS "${HDF5_SOURCE_DIR}/java" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/java")
endif ()
#-----------------------------------------------------------------------------
+# Generate the H5pubconf.h file containing user settings needed by compilation
+#-----------------------------------------------------------------------------
+configure_file (${HDF_RESOURCES_DIR}/H5pubconf.h.in ${HDF5_SRC_BINARY_DIR}/H5pubconf.h @ONLY)
+
+#-----------------------------------------------------------------------------
# Option to build examples
#-----------------------------------------------------------------------------
if (EXISTS "${HDF5_SOURCE_DIR}/HDF5Examples" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/HDF5Examples")
@@ -1166,9 +1171,4 @@ if (EXISTS "${HDF5_SOURCE_DIR}/HDF5Examples" AND IS_DIRECTORY "${HDF5_SOURCE_DIR
endif ()
endif ()
-#-----------------------------------------------------------------------------
-# Generate the H5pubconf.h file containing user settings needed by compilation
-#-----------------------------------------------------------------------------
-configure_file (${HDF_RESOURCES_DIR}/H5pubconf.h.in ${HDF5_SRC_BINARY_DIR}/H5pubconf.h @ONLY)
-
include (CMakeInstallation.cmake)