summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2022-05-13 02:53:45 (GMT)
committerGitHub <noreply@github.com>2022-05-13 02:53:45 (GMT)
commita30342e1d7012680c3fa48d3f889e033c0ada009 (patch)
tree31ce5f1729360b7fd7c1807a5d748614a5c875ae /CMakeLists.txt
parentb9dc83934df91a27d16304bb00ac54648c01ef93 (diff)
downloadhdf5-a30342e1d7012680c3fa48d3f889e033c0ada009.zip
hdf5-a30342e1d7012680c3fa48d3f889e033c0ada009.tar.gz
hdf5-a30342e1d7012680c3fa48d3f889e033c0ada009.tar.bz2
Allows parallel + thread-safe combination in Autotools and CMake (#1760)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 0 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cad378b..018c46d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -830,15 +830,6 @@ if (HDF5_ENABLE_THREADSAFE)
message (VERBOSE " **** thread-safety option will not be used building static library **** ")
endif ()
endif ()
- if (HDF5_ENABLE_PARALLEL)
- if (NOT ALLOW_UNSUPPORTED)
- message (FATAL_ERROR " **** parallel and thread-safety options are not supported, override with ALLOW_UNSUPPORTED option **** ")
- else ()
- if (CMAKE_VERSION VERSION_GREATER_EQUAL "3.15.0")
- message (VERBOSE " **** Allowing unsupported parallel and thread-safety options **** ")
- endif ()
- endif ()
- endif ()
if (HDF5_BUILD_FORTRAN)
if (NOT ALLOW_UNSUPPORTED)
message (FATAL_ERROR " **** Fortran and thread-safety options are not supported, override with ALLOW_UNSUPPORTED option **** ")