summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2024-01-29 19:13:33 (GMT)
committerGitHub <noreply@github.com>2024-01-29 19:13:33 (GMT)
commitd79667eb0c57d729c1801ad58b2deb121aca0466 (patch)
treea8114150c58f4e551181e523776b9bc9bae04457 /CMakeLists.txt
parent365e23340cd001ee751da366235ae420156ad728 (diff)
downloadhdf5-d79667eb0c57d729c1801ad58b2deb121aca0466.zip
hdf5-d79667eb0c57d729c1801ad58b2deb121aca0466.tar.gz
hdf5-d79667eb0c57d729c1801ad58b2deb121aca0466.tar.bz2
Add API support for Fortran MPI_F08 module definitions. (#3959)
* revert to using c-stub for _F08 MPI APIs * use mpi compiler wrappers for cmake and nvhpc
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f536a4a..505d55d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1085,6 +1085,13 @@ if (EXISTS "${HDF5_SOURCE_DIR}/fortran" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/for
if (MPI_Fortran_LINK_FLAGS)
set (CMAKE_Fortran_EXE_LINKER_FLAGS "${MPI_Fortran_LINK_FLAGS} ${CMAKE_EXE_LINKER_FLAGS}")
endif ()
+ # Check if MPI-3 Fortran 2008 module mpi_f08 is supported
+ if (MPI_Fortran_HAVE_F08_MODULE)
+ set (H5_HAVE_MPI_F08 1)
+ message (VERBOSE "MPI-3 Fortran 2008 module mpi_f08 is supported")
+ else ()
+ message (VERBOSE "MPI-3 Fortran 2008 module mpi_f08 is NOT supported")
+ endif ()
endif ()
#option (HDF5_INSTALL_MOD_FORTRAN "Copy FORTRAN mod files to include directory (NO SHARED STATIC)" "NO")