summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2019-02-07 18:07:26 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2019-02-07 18:07:26 (GMT)
commit865e35ea01731ab1f49187468f590cd0136ef78b (patch)
tree030cb77ea6086eb5d6fc5e21f9abcf8baaa17df0 /CMakeLists.txt
parentc7977ec2f896d933d59101db4c0f67ccce1fb62f (diff)
parent36e3d1600a3f9d771cfb9b4475f23c57d4b10280 (diff)
downloadhdf5-865e35ea01731ab1f49187468f590cd0136ef78b.zip
hdf5-865e35ea01731ab1f49187468f590cd0136ef78b.tar.gz
hdf5-865e35ea01731ab1f49187468f590cd0136ef78b.tar.bz2
Merge pull request #1524 in HDFFV/hdf5 from ~BYRN/hdf5_adb:develop to develop
* commit '36e3d1600a3f9d771cfb9b4475f23c57d4b10280': Refactor out timeout values Correct name of variable Remove F2003 Option and references Remove obsolete file Update examples version Update to example reference version Switch OFF if compression source is not available Fail configure if SZIP/ZLIB is requested but not found
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 85f701e..b9cdf4d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -758,6 +758,11 @@ if (BUILD_TESTING)
"Timeout in seconds for each test (default 1200=20minutes)"
)
+ # Generate a list of timeouts based on DART_TESTING_TIMEOUT
+ math (EXPR CTEST_SHORT_TIMEOUT "${DART_TESTING_TIMEOUT} / 2")
+ math (EXPR CTEST_LONG_TIMEOUT "${DART_TESTING_TIMEOUT} * 2")
+ math (EXPR CTEST_VERY_LONG_TIMEOUT "${DART_TESTING_TIMEOUT} * 3")
+
option (HDF5_TEST_VFD "Execute tests with different VFDs" OFF)
mark_as_advanced (HDF5_TEST_VFD)
if (HDF5_TEST_VFD)
@@ -835,9 +840,6 @@ set (H5_FC_FUNC_ "H5_FC_FUNC_(name,NAME) name ## _")
if (EXISTS "${HDF5_SOURCE_DIR}/fortran" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/fortran")
option (HDF5_BUILD_FORTRAN "Build FORTRAN support" OFF)
if (HDF5_BUILD_FORTRAN)
-
- option (HDF5_ENABLE_F2003 "Enable FORTRAN 2003 Standard" ON)
-
include (${HDF_RESOURCES_EXT_DIR}/HDFUseFortran.cmake)
message (STATUS "Fortran compiler ID is ${CMAKE_Fortran_COMPILER_ID}")
@@ -850,10 +852,8 @@ if (EXISTS "${HDF5_SOURCE_DIR}/fortran" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/for
include (${HDF_RESOURCES_DIR}/HDF5UseFortran.cmake)
set (LINK_Fortran_LIBS ${LINK_LIBS})
- if (HDF5_ENABLE_F2003)
- if (NOT FORTRAN_HAVE_ISO_C_BINDING)
- set (HDF5_ENABLE_F2003 OFF)
- endif ()
+ if (NOT H5_FORTRAN_HAVE_ISO_C_BINDING)
+ message (FATAL_ERROR " **** Fortran compiler lacks required Fortran 2003 features; unsupported Fortran 2003 compiler, disable HDF5_BUILD_FORTRAN **** ")
endif ()
# Parallel IO usage requires MPI to be Linked and Included