summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2023-10-08 01:16:30 (GMT)
committerGitHub <noreply@github.com>2023-10-08 01:16:30 (GMT)
commit6edd9a0aab0d80b64b6038ba2942315cdcc4d0db (patch)
tree1af0eb10740c59c87e14d8b11d32ae8f61894c48 /CMakeLists.txt
parent07347cc5dd62b75587eff7db30c6420de4b9b73f (diff)
downloadhdf5-6edd9a0aab0d80b64b6038ba2942315cdcc4d0db.zip
hdf5-6edd9a0aab0d80b64b6038ba2942315cdcc4d0db.tar.gz
hdf5-6edd9a0aab0d80b64b6038ba2942315cdcc4d0db.tar.bz2
Drop MPI-2 support (#3643)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3aca31f..c466487 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -671,6 +671,12 @@ if (HDF5_ENABLE_PARALLEL)
find_package(MPI REQUIRED)
if (MPI_C_FOUND)
set (H5_HAVE_PARALLEL 1)
+
+ # Require MPI standard 3.0 and greater
+ if (MPI_VERSION LESS 3)
+ message (FATAL_ERROR "HDF5 requires MPI standard 3.0 or greater")
+ endif ()
+
# MPI checks, only do these if MPI_C_FOUND is true, otherwise they always fail
# and once set, they are cached as false and not regenerated
set (CMAKE_REQUIRED_LIBRARIES "${MPI_C_LIBRARIES}")