summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2020-04-24 21:23:28 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2020-04-24 21:23:28 (GMT)
commit64fa9327d008c0c3d17c9489c32d99e0d514f88e (patch)
tree3203102f6a82d152085e5c01ec61d39c10c295a8 /CMakeLists.txt
parent709464301a058e8d44407d94e00919b926721f34 (diff)
downloadhdf5-64fa9327d008c0c3d17c9489c32d99e0d514f88e.zip
hdf5-64fa9327d008c0c3d17c9489c32d99e0d514f88e.tar.gz
hdf5-64fa9327d008c0c3d17c9489c32d99e0d514f88e.tar.bz2
Add "override with" to error message
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 922e814..b559446 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -777,28 +777,28 @@ if (HDF5_ENABLE_THREADSAFE)
endif ()
if (HDF5_ENABLE_PARALLEL)
if (NOT ALLOW_UNSUPPORTED)
- message (FATAL_ERROR " **** parallel and thread-safety options are not supported, use ALLOW_UNSUPPORTED option **** ")
+ message (FATAL_ERROR " **** parallel and thread-safety options are not supported, override with ALLOW_UNSUPPORTED option **** ")
else ()
message (STATUS " **** Allowing unsupported parallel and thread-safety options **** ")
endif ()
endif ()
if (HDF5_BUILD_FORTRAN)
if (NOT ALLOW_UNSUPPORTED)
- message (FATAL_ERROR " **** Fortran and thread-safety options are not supported, use ALLOW_UNSUPPORTED option **** ")
+ message (FATAL_ERROR " **** Fortran and thread-safety options are not supported, override with ALLOW_UNSUPPORTED option **** ")
else ()
message (STATUS " **** Allowing unsupported Fortran and thread-safety options **** ")
endif ()
endif ()
if (HDF5_BUILD_CPP_LIB)
if (NOT ALLOW_UNSUPPORTED)
- message (FATAL_ERROR " **** C++ and thread-safety options are not supported, use ALLOW_UNSUPPORTED option **** ")
+ message (FATAL_ERROR " **** C++ and thread-safety options are not supported, override with ALLOW_UNSUPPORTED option **** ")
else ()
message (STATUS " **** Allowing unsupported C++ and thread-safety options **** ")
endif ()
endif ()
if (HDF5_BUILD_HL_LIB)
if (NOT ALLOW_UNSUPPORTED)
- message (FATAL_ERROR " **** HL and thread-safety options are not supported, use ALLOW_UNSUPPORTED option **** ")
+ message (FATAL_ERROR " **** HL and thread-safety options are not supported, override with ALLOW_UNSUPPORTED option **** ")
else ()
message (STATUS " **** Allowing unsupported HL and thread-safety options **** ")
endif ()
@@ -1014,7 +1014,7 @@ if (EXISTS "${HDF5_SOURCE_DIR}/c++" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/c++")
# check for unsupported options
if (HDF5_ENABLE_PARALLEL)
if (NOT ALLOW_UNSUPPORTED)
- message (FATAL_ERROR " **** Parallel and C++ options are mutually exclusive, use ALLOW_UNSUPPORTED option **** ")
+ message (FATAL_ERROR " **** Parallel and C++ options are mutually exclusive, override with ALLOW_UNSUPPORTED option **** ")
else ()
message (STATUS " **** Allowing unsupported Parallel and C++ options **** ")
endif ()