summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2019-07-16 16:38:10 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2019-07-17 16:58:05 (GMT)
commit741ef0aaefb64ead937d86c5e30c9fbc97f69597 (patch)
tree7668507f8158c470f190e22d307fd007479fc5d3 /CMakeLists.txt
parent3ea746014a7e905b6a6d668bcc4c6305e76b5ec2 (diff)
downloadhdf5-741ef0aaefb64ead937d86c5e30c9fbc97f69597.zip
hdf5-741ef0aaefb64ead937d86c5e30c9fbc97f69597.tar.gz
hdf5-741ef0aaefb64ead937d86c5e30c9fbc97f69597.tar.bz2
HDFFV-10845 skip test if CMake command doesn't support ignore EOL
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a62561f..95d24bb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,6 +28,12 @@ if (CMAKE_CURRENT_SOURCE_DIR STREQUAL CMAKE_CURRENT_BINARY_DIR)
)
endif ()
+# CMake version 3.14 added option --ignore-eol to compare files
+# cmake -E compare_files --ignore-eol file1 file2
+#if(CMAKE_VERSION VERSION_LESS "3.14.0" AND WIN32)
+# MESSAGE(FATAL_ERROR "Windows builds requires a minimum of CMake 3.14")
+#endif()
+
#-----------------------------------------------------------------------------
# Instructions for use : Sub-Project Build
#