summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2023-06-13 03:01:34 (GMT)
committerGitHub <noreply@github.com>2023-06-13 03:01:34 (GMT)
commit8265bf31c9a584e4c1c9255bf57d7a875d8829bd (patch)
tree56dadecbf648ffb08fd6912669faabc23769d2bb /CMakeLists.txt
parentb9f988ed63c74e562e1c5634207fe4cdff4d17f2 (diff)
downloadhdf5-8265bf31c9a584e4c1c9255bf57d7a875d8829bd.zip
hdf5-8265bf31c9a584e4c1c9255bf57d7a875d8829bd.tar.gz
hdf5-8265bf31c9a584e4c1c9255bf57d7a875d8829bd.tar.bz2
Fix the default for API_VERSION to only allow one default (#3107)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0801e0f..29ac320 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -794,9 +794,6 @@ endif ()
#-----------------------------------------------------------------------------
# Option to use 1.12.x API
#-----------------------------------------------------------------------------
-if (NOT DEFAULT_API_VERSION)
- set (DEFAULT_API_VERSION "v112")
-endif ()
set (H5_USE_112_API_DEFAULT 0)
if (DEFAULT_API_VERSION MATCHES "v112")
set (H5_USE_112_API_DEFAULT 1)
@@ -805,9 +802,6 @@ endif ()
#-----------------------------------------------------------------------------
# Option to use 1.14.x API
#-----------------------------------------------------------------------------
-if (NOT DEFAULT_API_VERSION)
- set (DEFAULT_API_VERSION "v114")
-endif ()
set (H5_USE_114_API_DEFAULT 0)
if (DEFAULT_API_VERSION MATCHES "v114")
set (H5_USE_114_API_DEFAULT 1)