summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2022-12-21 18:07:25 (GMT)
committerGitHub <noreply@github.com>2022-12-21 18:07:25 (GMT)
commit9f5cf0a45748fcb7ced4f4619d7c6c76cb3f67ab (patch)
tree2f237d0865fa37db7ad56d7182978db4258488fa /CMakeLists.txt
parent976e8c97504cfbce40c565b02a01d29006350c6b (diff)
downloadhdf5-9f5cf0a45748fcb7ced4f4619d7c6c76cb3f67ab.zip
hdf5-9f5cf0a45748fcb7ced4f4619d7c6c76cb3f67ab.tar.gz
hdf5-9f5cf0a45748fcb7ced4f4619d7c6c76cb3f67ab.tar.bz2
H5F_LIBVER_LATEST changes for move to 1.15 (#2288)
* H5F_LIBVER_LATEST changes for move to 1.15 * Add new default api check * Format fixes * Fix default configure * fix lib version tests * Fix another version variable * Add 1.14 doc link
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 31cae2e..1c85965 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -813,6 +813,17 @@ if (DEFAULT_API_VERSION MATCHES "v114")
endif ()
#-----------------------------------------------------------------------------
+# Option to use 1.16.x API
+#-----------------------------------------------------------------------------
+if (NOT DEFAULT_API_VERSION)
+ set (DEFAULT_API_VERSION "v116")
+endif ()
+set (H5_USE_116_API_DEFAULT 0)
+if (DEFAULT_API_VERSION MATCHES "v116")
+ set (H5_USE_116_API_DEFAULT 1)
+endif ()
+
+#-----------------------------------------------------------------------------
# Include user macros
#-----------------------------------------------------------------------------
include (UserMacros.cmake)