summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2011-04-11 20:52:09 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2011-04-11 20:52:09 (GMT)
commita835d1e65a3dbae4feca742db93d0b2e1a9ff29c (patch)
tree0c033a3c61aa19c512849d8ee9115c967ffd7c12 /CMakeLists.txt
parenta67dbbaf810f44b7b05a72fa38fa1da621651896 (diff)
downloadhdf5-a835d1e65a3dbae4feca742db93d0b2e1a9ff29c.zip
hdf5-a835d1e65a3dbae4feca742db93d0b2e1a9ff29c.tar.gz
hdf5-a835d1e65a3dbae4feca742db93d0b2e1a9ff29c.tar.bz2
[svn-r20472] Add message that H5_HAVE_WIN_THREADS requires WINVER >= 0x600 (VISTA or WIN7)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5bfabef..d17ec97 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -608,8 +608,9 @@ IF (WIN32 AND NOT CYGWIN)
IF (HDF5_ENABLE_PARALLEL)
MESSAGE (FATAL " **** Parallel and Threadsafe options are mutually exclusive **** ")
ENDIF (HDF5_ENABLE_PARALLEL)
- SET (H5_HAVE_WIN_THREADS 1)
SET (H5_HAVE_THREADSAFE 1)
+ SET (H5_HAVE_WIN_THREADS 1)
+ MESSAGE (STATUS " **** Windows Threads only available in WINVER>=0x600 (Vista or Windows 7)**** ")
ENDIF (HDF5_ENABLE_THREADSAFE)
ENDIF (WIN32 AND NOT CYGWIN)