summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2021-04-20 11:55:05 (GMT)
committerGitHub <noreply@github.com>2021-04-20 11:55:05 (GMT)
commitfc5c567fdce94765c9db904295ca8879a8e91752 (patch)
tree91879906198b94a23324ed9fc6d989c981bfacda /CMakeLists.txt
parentd3384b2e8e5fafd9f3aa90e738ca18d5ddeeb3c1 (diff)
downloadhdf5-fc5c567fdce94765c9db904295ca8879a8e91752.zip
hdf5-fc5c567fdce94765c9db904295ca8879a8e91752.tar.gz
hdf5-fc5c567fdce94765c9db904295ca8879a8e91752.tar.bz2
CMake no longer builds the C++ library by default (#555)
* Committing clang-format changes * CMake no longer builds C++ library by default Co-authored-by: github-actions <41898282+github-actions[bot]@users.noreply.github.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0771ac6..306f701 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1106,7 +1106,7 @@ endif ()
# Option to build HDF5 C++ Library
#-----------------------------------------------------------------------------
if (EXISTS "${HDF5_SOURCE_DIR}/c++" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/c++")
- option (HDF5_BUILD_CPP_LIB "Build HDF5 C++ Library" ON)
+ option (HDF5_BUILD_CPP_LIB "Build HDF5 C++ Library" OFF)
if (HDF5_BUILD_CPP_LIB)
# check for unsupported options
if (HDF5_ENABLE_PARALLEL)