summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2014-09-03 19:04:18 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2014-09-03 19:04:18 (GMT)
commit5a4357e4fb0b920c46cae32e446a662dd44ed7f9 (patch)
tree32b62e2f670ca1565689c28ade8f1bdbdb72ee6c /CMakeLists.txt
parentc23f3a7ea577b66f103ab06e9310e819c13f5401 (diff)
downloadhdf5-5a4357e4fb0b920c46cae32e446a662dd44ed7f9.zip
hdf5-5a4357e4fb0b920c46cae32e446a662dd44ed7f9.tar.gz
hdf5-5a4357e4fb0b920c46cae32e446a662dd44ed7f9.tar.bz2
[svn-r25570] UNDO:Added option to build tools static when building shared libraries. This will prevent 'dll' being appended to the tool name on windows. See HDFFV-8292.
Windows DLL linkage problem because of defines needed. Tested: local linux
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a584e89..6877b6a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -283,8 +283,8 @@ if (BUILD_SHARED_LIBS)
else (BUILD_SHARED_LIBS)
set (H5_BUILT_AS_STATIC_LIB 1)
set (H5_ENABLE_STATIC_LIB YES)
+ set (CMAKE_POSITION_INDEPENDENT_CODE ON)
endif (BUILD_SHARED_LIBS)
-set (CMAKE_POSITION_INDEPENDENT_CODE ON)
#-----------------------------------------------------------------------------
# Option to Build Static executables