summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2022-06-09 13:35:33 (GMT)
committerGitHub <noreply@github.com>2022-06-09 13:35:33 (GMT)
commit8b54201509257e3d2cd968dfae8bcda1ddef4988 (patch)
treedbad0c2fcb93ae91ca2467b1f3ef7221789bbf3b /CMakeLists.txt
parentacb6e2da30466aeec3300b462389b3aee344d586 (diff)
downloadhdf5-8b54201509257e3d2cd968dfae8bcda1ddef4988.zip
hdf5-8b54201509257e3d2cd968dfae8bcda1ddef4988.tar.gz
hdf5-8b54201509257e3d2cd968dfae8bcda1ddef4988.tar.bz2
Develop sync (#1793)
* Synch update * Branch sync changes
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fb074e2..5599441 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,10 +2,13 @@ cmake_minimum_required (VERSION 3.12)
project (HDF5 C)
if (POLICY CMP0074)
+ # find_package() uses <PackageName>_ROOT variables.
cmake_policy (SET CMP0074 NEW)
endif ()
if (POLICY CMP0083)
+ # To control generation of Position Independent Executable (PIE) or not,
+ # some flags are required at link time.
cmake_policy (SET CMP0083 NEW)
endif ()