summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2013-06-10 17:46:48 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2013-06-10 17:46:48 (GMT)
commitfeb14ea872ed5889de014e35c421b37501fbe38a (patch)
tree28a7eb1eb0961fb3db0f67306fb0efd1cc550258 /CMakeLists.txt
parent001f6a53bff1ff0a074e52a31ee9ce3e61a0e7ce (diff)
downloadhdf5-feb14ea872ed5889de014e35c421b37501fbe38a.zip
hdf5-feb14ea872ed5889de014e35c421b37501fbe38a.tar.gz
hdf5-feb14ea872ed5889de014e35c421b37501fbe38a.tar.bz2
[svn-r23745] HDFFV-8461: Add Windows /MT support
This adds the UserMacros.cmake support needed.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 66c3555..e14fc21 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -351,6 +351,8 @@ ENDIF (WIN32)
IF (MSVC)
SET (CMAKE_MFC_FLAG 0)
+ SET (WIN_COMPILE_FLAGS "/MD")
+ SET (WIN_LINK_FLAGS "")
ENDIF (MSVC)
SET (MAKE_SYSTEM)
@@ -522,6 +524,11 @@ IF (HDF5_USE_18_API_DEFAULT)
ENDIF (HDF5_USE_18_API_DEFAULT)
#-----------------------------------------------------------------------------
+# Include user macros
+#-----------------------------------------------------------------------------
+INCLUDE (UserMacros.cmake)
+
+#-----------------------------------------------------------------------------
# Options for HDF5 Filters
#-----------------------------------------------------------------------------
MACRO (HDF5_SETUP_FILTERS FILTER)