summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-04-24 22:22:55 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-04-24 22:22:55 (GMT)
commitbc9a773b994cde788e97e5e998eb5fcd21ec8a39 (patch)
treebd36f898f393eb39c27cc654ab74fb2c43a666a4 /CMakeLists.txt
parentb3c5284692093953132c6c8227e0980b670bf4ad (diff)
downloadhdf5-bc9a773b994cde788e97e5e998eb5fcd21ec8a39.zip
hdf5-bc9a773b994cde788e97e5e998eb5fcd21ec8a39.tar.gz
hdf5-bc9a773b994cde788e97e5e998eb5fcd21ec8a39.tar.bz2
TRILABS-20 Fix fortran configure during fix of CXX configure
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d3afc41..825b590 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -834,6 +834,9 @@ if (EXISTS "${HDF5_SOURCE_DIR}/c++" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/c++")
message (STATUS " **** Allowing unsupported Parallel and C++ options **** ")
endif ()
endif ()
+
+ include (${HDF_RESOURCES_EXT_DIR}/HDFUseCXX.cmake)
+
if (CMAKE_NO_STD_NAMESPACE)
set (H5_NO_STD 1)
endif ()
@@ -852,7 +855,7 @@ endif ()
# being built then configure should fail due to bug HDFFV-889.
#-----------------------------------------------------------------------------
if (HDF5_BUILD_FORTRAN AND HDF5_BUILD_HL_LIB)
- if (NOT FORTRAN_DEFAULT_REAL_NOT_DOUBLE)
+ if (NOT H5_FORTRAN_DEFAULT_REAL_NOT_DOUBLE)
message (FATAL_ERROR " **** Fortran high-level routines are not supported when the default REAL is DOUBLE PRECISION, use HDF5_BUILD_HL_LIB:BOOL=OFF **** ")
endif ()
endif ()