summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2021-03-01 21:54:27 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2021-03-01 21:54:27 (GMT)
commitd7b277a22aa72f3badcc331e3007df8892e83a80 (patch)
treedf63cc53b0f0aae8ffa8ad58fe31f21aff71c79b /CMakeLists.txt
parent051cf5330ba06f113de88de22c201f00677cbdc3 (diff)
downloadhdf5-d7b277a22aa72f3badcc331e3007df8892e83a80.zip
hdf5-d7b277a22aa72f3badcc331e3007df8892e83a80.tar.gz
hdf5-d7b277a22aa72f3badcc331e3007df8892e83a80.tar.bz2
Improves autotools and CMake support for sigtimedwait alternative
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ac291fa..b6e0044 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -816,8 +816,13 @@ if (HDF5_ENABLE_THREADSAFE)
if (Threads_FOUND)
set (H5_HAVE_THREADSAFE 1)
endif ()
+else()
+ # Always check for pthreads for VFD SWMR (for now)
+ set (THREADS_PREFER_PTHREAD_FLAG ON)
+ find_package (Threads REQUIRED)
endif ()
+
#-----------------------------------------------------------------------------
# Option to build the map API
#-----------------------------------------------------------------------------